cancel
Showing results for 
Search instead for 
Did you mean: 

Apple Watch Ultra Disconnecting from Cellular Data and only connects again if watch is restarted

mobileappz
Level 3: Thinker
  • 35 Posts
  • 2 Topics
  • 0 Solutions
Registered:

Hi, I'm experiencing some issues with the cellular connection on an Apple Watch Ultra. The cellular data connection drops and does not come back unless the Watch is restarted. This problems occurs when using the  watch for cellular features. ie when it is not connected on a Wifi or iPhone connection. This is in an area with good 4G cellular coverage, the network coverage is not causing the problem.

The Apple Watch connects to cellular data when it's first switched on, and it works and can receive data. It says when you tap on the cellular bars:

"Mobile Data - O2 UK - 4G". And it says when on tapping the big green cellular icon: Status: Connected.

The problem is when moving to an area of low signal, then back to the full signal area, it is impossible for the Watch to reconnect to a full signal, even when clearly back in the full signal area. 

It says when you tap on the cellular bars, even when moving back in to the 4G area:

"Mobile Data - O2 UK". And it says when on tapping the big green cellular icon: Status: Loading.

 The only way to cellular data reception back is to restart the Apple Watch. This obviously resets the data connection.

I have tried all the usual remedies: Unpair and factory reset Apple Watch, Remove and re-add Apple Watch data plan in the Apple Watch App on the iPhone, switch cellular data on and off on Watch and switch flight mode on and off on Watch. However the only way it regains data reception is restarting the Apple Watch.

Message 1 of 233
42,089 Views
232 REPLIES 232

Ziggy37
Level 1: Joiner
  • 1 Posts
  • 0 Topics
  • 0 Solutions
Registered:

Hi @O2Helen01 @O2Emma , I am having the same problem with my series 8 apple watch. It drops the signal when I go running without my phone and the only way to restore the connection is to power down the watch and restart it. All help gratefully received!

Message 191 of 233
2,224 Views

pgn
Level 76: Forum Legend
  • 37472 Posts
  • 239 Topics
  • 1706 Solutions
Registered:

@Ziggy37 wrote:

Hi O2Helen01 O2Emma  , I am having the same problem with my series 8 apple watch. It drops the signal when I go running without my phone and the only way to restore the connection is to power down the watch and restart it. All help gratefully received!


@Ziggy37 - the next O2 Advisor on duty will be @O2Sarah- after 9am Monday (bank holiday weekend in UK) - hopefully she'll see this tag and be able to get in touch with you via Private Message on here then. Good luck!

Message 192 of 233
2,219 Views

O2Sarah-
  • 689 Posts
  • 0 Topics
  • 25 Solutions
Registered:

Thanks for the tag @pgn 

@Ziggy37 I will send you a private message so we can look into this 🙂

 

Message 193 of 233
2,202 Views

kitenski
Level 2: Apprentice
  • 17 Posts
  • 1 Topics
  • 0 Solutions
Registered:

I followed the info in this message which fixed and stayed fix the issues for me

 

https://community.o2.co.uk/t5/Tech-Support/Apple-Watch-Ultra-Disconnecting-from-Cellular-Data-and-on...

Message 194 of 233
2,174 Views

pgn
Level 76: Forum Legend
  • 37472 Posts
  • 239 Topics
  • 1706 Solutions
Registered:

@kitenski wrote:

I followed the info in this message which fixed and stayed fix the issues for me

 

https://community.o2.co.uk/t5/Tech-Support/Apple-Watch-Ultra-Disconnecting-from-Cellular-Data-and-on...


Well done, @kitenski - did you have to upgrade both watch and phone to latest o/s as well?

Message 195 of 233
2,163 Views

kitenski
Level 2: Apprentice
  • 17 Posts
  • 1 Topics
  • 0 Solutions
Registered:

I can't remember as it was Nov 22 when I got it fixed, but as a rule I'm always on the latest versions.

Message 196 of 233
2,156 Views

AngryWarlock
Level 4: Observant
  • 81 Posts
  • 5 Topics
  • 0 Solutions
Registered:

Hi @O2Helen01 @O2Emma 

I have the same problem as everyone else in the 20 page thread - AWU connects to data, then drops a short while later. Resetting everything has the same effect - connects........then drops. I've reinstalled the e-sim. that didn't work. 

Im within my 14 day return window. Can you help me fix this beforee I need to send it back and walk away please ?

Message 197 of 233
2,107 Views

O2Emma
  • 1198 Posts
  • 0 Topics
  • 34 Solutions
Registered:

Hi @AngryWarlock I will send you a private message to look into it for you.

signature
Message 198 of 233
2,105 Views

vratush
Level 1: Joiner
  • 1 Posts
  • 0 Topics
  • 0 Solutions
Registered:

Hi all. I’ve had my AWU for a few months, not migrating from another plan, but the same issue started today for me. Is the only solution still to go through the 202 in hopes of getting to a rep who gets it?

Message 199 of 233
2,072 Views

RougeFlight
Level 1: Joiner
  • 3 Posts
  • 1 Topics
  • 0 Solutions
Registered:

Hi @O2Helen01 @O2Emma @O2Jonathan , I am having the same problem with my series 8 cellular apple watch. It drops the signal when I’m out working without my phone and the only way to restore the connection is to power down the watch and restart it.

 

Watch had a “update network settings” notification today, but unsure what if anything it changed.

 

All help gratefully received!

Message 200 of 233
2,022 Views