Showing results for 
Search instead for 
Did you mean: 

Apple Watch Ultra Disconnecting from Cellular Data and only connects again if watch is restarted

Level 3: Thinker
  • 35 Posts
  • 2 Topics
  • 0 Solutions

Hi, I'm experiencing some issues with the cellular connection on an Apple Watch Ultra. The cellular data connection drops and does not come back unless the Watch is restarted. This problems occurs when using the  watch for cellular features. ie when it is not connected on a Wifi or iPhone connection. This is in an area with good 4G cellular coverage, the network coverage is not causing the problem.

The Apple Watch connects to cellular data when it's first switched on, and it works and can receive data. It says when you tap on the cellular bars:

"Mobile Data - O2 UK - 4G". And it says when on tapping the big green cellular icon: Status: Connected.

The problem is when moving to an area of low signal, then back to the full signal area, it is impossible for the Watch to reconnect to a full signal, even when clearly back in the full signal area. 

It says when you tap on the cellular bars, even when moving back in to the 4G area:

"Mobile Data - O2 UK". And it says when on tapping the big green cellular icon: Status: Loading.

 The only way to cellular data reception back is to restart the Apple Watch. This obviously resets the data connection.

I have tried all the usual remedies: Unpair and factory reset Apple Watch, Remove and re-add Apple Watch data plan in the Apple Watch App on the iPhone, switch cellular data on and off on Watch and switch flight mode on and off on Watch. However the only way it regains data reception is restarting the Apple Watch.

Message 1 of 233

Accepted Solutions

Level 2: Apprentice
  • 2 Posts
  • 0 Topics
  • 1 Solutions

I have a solution that is so far (touch wood) working for me on an AW-Ultra. Had the 6 before and ‘migrated’ the data connection to the new watch. It would appear that there is an issue on O2 servers when migrating eSims from one watch to another (I was experiencing all the familiar problems having to restart the AW-Ultra often and then only getting 4G for a limited time if at all).


Happy to report after this ‘fix’ I appear to have kept the data connection, even after going into areas of poor reception where my phone normally looses signal and 4G is being restored once I have good coverage again.


**The Fix**


Remove the account under [Mobile Data] using the Watch App on your iPhone.


Call 202 and explain the issue and request to be put through to the retentions team for immediate removal of the watch (sync-1/sync-2) service from your account. They will try and tell you it takes 30 days, however explain you are doing this to ‘refresh’ your service and that you will be resigning immediately as soon as it has been removed from the account, they then should agree to stop the service straight away.


Wait 10-15 minutes


Back in the Watch App on iPhone, go back into [Mobile Data] and sign up for a totally new service, agree to the terms and conditions, wait for the setup to complete.


Wait up to 24 hours for the new service to be active (was 20 minutes for me).



Hope this helps people - good luck



View solution in original post

Message 122 of 233
232 REPLIES 232

Former Staff
  • 1808 Posts
  • 117 Topics
  • 17 Solutions

Hi @mobileappz this might be a better one for the Apple Community. 

Have you checked the battery saver settings such as in this case: 


Probably not as simple as that but might be worth giving it a try.

Message 2 of 233

  • 35 Posts
  • 2 Topics
  • 0 Solutions

Hi, thanks for the info, that's interesting, I looked in to that setting on the watch and it was disabled so don't think that was the cause. Currently awaiting a ESIM reset from O2 which I hope will resolve the issue. Appreciate your help.

Message 3 of 233

Not applicable

Hi, did the ESIM reset work? I’m experiencing the exact same problems you describe with my Apple Watch Ultra and O2. A restart of my watch gives me cellular connectivity, but after a period of time it just reverts to ‘Not Connected’ or simply says ‘Loading’. Cellular worked fine on my Apple Watch 5 + I’m in an area of very good coverage. When my watch does work, 4G is very good and fast. 

Message 4 of 233

Level 77: Grand Master
  • 10819 Posts
  • 59 Topics
  • 3117 Solutions

@Anonymous @mobileappz 


It might be worth reaching out to Apple direct as they are investigating numerous issues with the Ultra and some of the functionality, not just cellular but also other things as well. 


- Xperia 1V - o2 and Spusu
- Pixel 8 Pro - o2 and Vodafone UK
Message 5 of 233

  • 35 Posts
  • 2 Topics
  • 0 Solutions

Hi, no, the ESIM reset didn't work. Same issues after the ESIM reset. I tried a new Apple Watch plan with TruPhone with the watch, which works with no data connectivity issues. This leads me to believe that the Apple Watch Ultra hardware and Apple WatchOS software is not at fault as it is able to maintain a cellular data connection on another carrier, even after it goes out of signal and the signal comes back. Apple Support suggested it was a carrier issue.

Message 6 of 233

  • 35 Posts
  • 2 Topics
  • 0 Solutions

Thanks, I have done so and they suggested it was a carrier issue. Which I believe is correct because the Apple Watch Ultra has now been tested and works and maintains a cellular data connection on another carrier, TruPhone.

Message 7 of 233

Not applicable

Thanks for the feedback. I’ve so far come across 2 other forums mentioning O2, the Ultra and connectivity issues. Whilst it’s not concrete evidence, it does suggest it’s an O2 carrier problem. 

Message 8 of 233

  • 4 Posts
  • 0 Topics
  • 0 Solutions

I have an Ultra on O2 Cellular and I have the same issues of having to turn off the watch and back on again. O2 should now be aware of this issue. I don’t know of any other Ultra users on other networks having an issue. 

Message 9 of 233

  • 8 Posts
  • 0 Topics
  • 0 Solutions

Hi there, did anyone manage to get a fix on this problem? I’ve reached out to both Apple and O2, and neither of them had any idea what to do. Apple have suggested replacing my watch, but I would have to send it back first, and then wait a few weeks as the Ultras are all out of stock at the moment. Not a great experience really. Anyone have any progress updates? What were the other forums people were discussing this issue on? Are we aware of any fixes coming from there?

Message 10 of 233