Welcome to the O2 Community

Has your question already been answered? See the community FAQ's
Reply
Anonymous
Posts: 0

NO SERVICE

My i phone 4 has just started exhibiting No Service in it's top left hand corner for no apparent reason, I am in credit and the phone is charged. I have tried switching off and back on to no avail!

 

Can anybody help please?

 

Nick Young

Anonymous
Posts: 0

Re: NO SERVICE

[ Edited ]
Check your service status http://status.o2.co.uk

Remove and clean your sim.

Settings , general, reset, reset network settings.

Help link http://community.o2.co.uk/t5/Pay-Monthly-and-Pay-Go/Self-help-guide-Is-the-network-down-for-me-or-ev...
Posts: 115,473
Topics: 571
Solutions: 15,807
Registered: ‎04-04-2012

Re: NO SERVICE

Usually a restart of the phone helps.
If not and the status checker shows OK you might want to try a sim swap.
Any O2 store can do this for free which is the easiest way or order one online from Live chat or call CS on 202.
I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Anonymous
Posts: 0

Re: NO SERVICE

Hi Nick, it's not your phone, there is something wrong with the service. Mines been on and off for the past couple of days
Posts: 83,915
Topics: 580
Solutions: 4,222
Registered: ‎04-01-2009

Re: NO SERVICE


@Anonymous wrote:
Hi Nick, it's not your phone, there is something wrong with the service. Mines been on and off for the past couple of days

Probably in a totally different area to yourself. Check your postcode for issues.

Service Status

Level 3: Thinker
Posts: 71
Registered: ‎26-09-2008

Re: NO SERVICE

I've had the same thing for the last few days.  Putting my iPhone 6 into Airplane mode and back out again seems to do the trick.

Posts: 115,473
Topics: 571
Solutions: 15,807
Registered: ‎04-04-2012

Re: NO SERVICE


@GeorgeStark wrote:

I've had the same thing for the last few days. 


If you are still using your old sim card, do a swap for a new one.

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Level 3: Thinker
Posts: 71
Registered: ‎26-09-2008

Re: NO SERVICE

[ Edited ]

I already swapped the SIMs for the new '4G enabled' SIM from O2.  I've never used my iPhone 6 with the old SIM from my iPhone 5.  There seem to be multiple reports of this happening, regardless of new SIM, old SIM, etc.

Posts: 115,473
Topics: 571
Solutions: 15,807
Registered: ‎04-04-2012

Re: NO SERVICE

OK, just asking - A few have reported the same issue fixed with a sim swap....
I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Level 3: Thinker
Posts: 71
Registered: ‎26-09-2008

Re: NO SERVICE

It's fine...that was a decent suggestion.  Just re-read my post and it came across like I was annoyed, which I absolutely wasn't.  :-)  I'll see how annoying this gets and take it from there...it just seems service related, based on the number of people reporting it with seemingly completely different scenarios (different models of iPhone, etc.).  Haven't come across anybody with a non-iOS phone report it yet...maybe it's an iOS 8.1 thing?