Welcome to the O2 Community

Has your question already been answered? See the community FAQ's

Pay Monthly

Reply
Highlighted
Level 1: Joiner
Posts: 6
Registered: ‎19-04-2014

02 signal gone but network says working fine

My elderly mum lives in a rural area but has always been able to get a good signal until now.  For the last 2 weeks the signal has gone. We've switched phones off and back on and tried 4 other different makes and models of phones but now none of them have got a signal where once they could make and receive calls, texts etc.  We've even been able to get 4G on two of the phones in the past but not any more.  we've raised several complaints with 02 but all it says is they couldn't find a fault !!  Whats going on with the signal ?   Help please 

Highlighted
Posts: 84,399
Topics: 715
Registered: ‎14-01-2013

Re: 02 signal gone but network says working fine

Hi @rusty51 Not sure what's going on. It may help if you download the My Network app where you can report issues https://www.o2.co.uk/apps/my-network

There is also a community guide here which may help https://community.o2.co.uk/t5/How-to-Guides/How-can-I-sort-out-my-network-issues/ba-p/1014088

If you aren't getting a good service then you need to make an official complaint https://www.o2.co.uk/how-to-complain

*The Game Is On*

Most-Helpful-MemberFriendliest-MemberMost-Useful-GuideBest-Feedbacker
Highlighted
Posts: 84,399
Topics: 715
Registered: ‎14-01-2013

Re: 02 signal gone but network says working fine

Another suggestion is to download the app called O2 Ask...where you can make calls over WiFi

https://www.o2.co.uk/help/apps/o2-ask

*The Game Is On*

Most-Helpful-MemberFriendliest-MemberMost-Useful-GuideBest-Feedbacker
Highlighted
Posts: 98,487
Topics: 545
Solutions: 12,384
Registered: ‎04-04-2012

Re: 02 signal gone but network says working fine

Ask customer services to send someone out from the network team to investigate the mast in your area.
If there are other people on o2 who are also suffering, get them to call and report it to. The more reports they get mean it more likely they will investigate it.
We have also known for masts to be removed completely for different reasons so that could also be a cause but you will have to keep badgering customer services until they do something about it I'm afraid.
Depending on your location the responsibility for repairs could also be O2 or Vodafone so that may take more time to fix too.
I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Highlighted
Level 1: Joiner
Posts: 6
Registered: ‎19-04-2014

Re: 02 signal gone but network says working fine

Thanks, I already have the My02 app. That's what I've used to complain before.
Highlighted
Posts: 84,399
Topics: 715
Registered: ‎14-01-2013

Re: 02 signal gone but network says working fine


@rusty51 wrote:
Thanks, I already have the My02 app. That's what I've used to complain before.

Then use the official complaints route @rusty51 You can use Resolver in the link I gave you

They are known to get good results whenever possible Resolver

Currently you are paying for a service which you aren't getting

Also think about using O2 Ask. Also given in my post above

*The Game Is On*

Most-Helpful-MemberFriendliest-MemberMost-Useful-GuideBest-Feedbacker
Highlighted
Posts: 98,487
Topics: 545
Solutions: 12,384
Registered: ‎04-04-2012

Re: 02 signal gone but network says working fine

Can you find other O2 users in the area to see if they are having the same problems?
It might also be worth getting a new sim just in case it's a sim card failure if others aren't having problems?
I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Highlighted
Level 1: Joiner
Posts: 7
Registered: ‎05-07-2013

Re: 02 signal gone but network says working fine

[ Edited ]

Hello I feel very sorry for you !! I am having just the same problems.Almost 6 weeks now!! I have spent hours on the phone,web chats apps All to no avail! Fobbed off at every turnJust dreadful I don't know what's going on either. I am not one to use these such forums but I did at the weekend and someone suggested I email the CEO Mark Evans. I had been asking for his email and phone number and got nothing from O2- they flatley refuse. However at someone else's suggestion I looked it on I think ceoemail.com. anyway did that emailed today and got the most positive response in all this time! Got reply back very quickly and a phone number too. !

Good luck!

Tim

Try that! 

Highlighted
Posts: 79,687
Topics: 570
Solutions: 3,778
Registered: ‎04-01-2009

Re: 02 signal gone but network says working fine

Highlighted
Former Staff
Posts: 5,426
Registered: ‎18-04-2018

Re: 02 signal gone but network says working fine

Hi @rusty51,  I just wanted to check if you made any progress with this since you last posted? slight smile

Access for You: Registration - Find out how to register for our Access for You service.
Want to chat with other fellow-minded members? Head to our Off-topic section for some interesting chit-chat.
Check out our Priority board for tickets & offers updates, and to discuss all things Priority-related!
Welcome to O2! - New to O2? Find out all you need to know to get started!


If you'd like to take part, why not register? Smiley Happy
signature