cancel
Showing results for 
Search instead for 
Did you mean: 

Galaxy S7 WiFi Calling Setting?

Anonymous
Not applicable

Hi all,

 

Have just upgraded to a Galaxy S7 (direct from O2). I've checked it has the latest firmware, it says it has. Have enabled WiFi and 4G calling through the My O2 app. I just can't for the life of me find where to turn on WiFi calling in the phone settings.

 

I've tried Settings-->Connections

 

I've tried going into the Phone app-->settings

 

Not in either. I've tried searching for WiFi calling in settings, nothing found.

 

The reported current version if I try a manual update of the phone's software (says I have the latest version) is G930FXXU1DQD7/G930FTEF1DQD1/G930FXXU1DQD7

 

Any ideas?

 

Thanks in advance.

Message 1 of 4
7,881 Views
1 ACCEPTED SOLUTION

Accepted Solutions

Anonymous
Not applicable

Problem solved. I had not done a re-boot since I enebled WiFi calling through the My O2 app. Doing so made the setting appear in settings-->connections.

View solution in original post

Message 2 of 4
7,876 Views
3 REPLIES 3

Anonymous
Not applicable

Problem solved. I had not done a re-boot since I enebled WiFi calling through the My O2 app. Doing so made the setting appear in settings-->connections.

View solution in original post

Message 2 of 4
7,877 Views

petcon
  • 1 Posts
  • 0 Topics
  • 0 Solutions
Registered:

I still have the same issue with my Galaxy S7 the "Wifi Calling" option doesn't always appear in my CONNECTIONS menu screen, hence I cannot switch ON Wifi Calling. I've been in contact (too many times to mention) with O2 and they state it's an issue they know about and Samsung are working on it. I contacted Samsung and they state it's not their problem it's an issue with my provider O2. That now completes the circle!!!!  As my mobile network signal at best is -120dbm  0 asu at my home address (and down my street) makes my mobile calls from home useless. Wifi Calling is the answer to my prayer, when it's working!  

I then contacted O2 complaints department and they stated that this issue is known about and are in consultation with Samsung to resolve the issue. The question is when, no time frame has been set!!

In the mean time I have to keep switching my device OFF and ON until the Wifi Calling option appears on the screen, then I can swtich it ON again. I guess my ON/OFF button will fail before the rest of the device. I will update this issue when and if it is resolved. Re-booting my device did not cure my problem.

Message 3 of 4
6,848 Views

jonsie
Level 94: Supreme
  • 85658 Posts
  • 591 Topics
  • 4583 Solutions
Registered:

I really hope Samsung and O2 sort this out quickly for you and others

Good luck ☺️ 

Message 4 of 4
6,844 Views