cancel
Showing results for 
Search instead for 
Did you mean: 

4G & Wi-fi Calling enable

GMF
Level 2: Apprentice
  • 10 Posts
  • 1 Topics
  • 1 Solutions
Registered:

I (and Customer Services) have a problem getting these services up and running on my new O2 Sim only contract (with ported in number from Vodafone).  I've enabled the service in MyO2.  All other services, including 4G (VoLTE Off) and Wifi work normally.

On my iPhone 11 Pro Max, when I attempt to select the "4G, VoLTE On" option I get the following error back "Cannot Activate 4G Calls, To enable 4G calls on this account, contact O2."   When I attempt to enable Wif-Fi calling I get this message "Wi-Fi Calling, To allow Wi-Fi calling on this account, contact O2."

I have tried the usual rebooting of the phone, resetting network settings and checking the apn details are correct.  I have also tried the sim in a Samsung Galaxy S8+, but the option to enable 4G calling is greyed out.  I've also been on different cell sites and different Wi-fi networks.

An O2 Guru tried removing the service from my account and then adding it again, but again this didn't make the service available on either device.  This has now exhausted the help O2 Customer Services can offer so I'm wondering if the wider community has any helpful ideas before I go grovelling back to Vodafone...

 

 

Message 1 of 20
1,478 Views
19 REPLIES 19

GMF
Level 2: Apprentice
  • 10 Posts
  • 1 Topics
  • 1 Solutions
Registered:

Hi @O2John and thanks for getting back to me.

 

Sorry for the slightly scattergun approach, can't believe I managed to miss the two you tagged in!

 

Yeah, I don't think this is a device issue either, but it'll be nice to get the issue bottomed out for everyone one way or another. Especially as this is such a deal breaker for those of us who use our phones indoors and only have a short cooling off period to establish if O2 is suitable!

Message 11 of 20
767 Views

O2John
  • 17 Posts
  • 0 Topics
  • 0 Solutions
Registered:

@GMF no problem at all. Just part of our escalation process as we have no account access.

 

I checked my suspicion with a colleague, same gut reaction that the issue is down to your devices not having O2 Accredited Firmware. If we're right (and we usually are pretty bang on with our gut reactions), this may not be resolvable.

 

Fingers crossed though. I'll leave it in the hands of the escalation process now. 

signature
Message 12 of 20
760 Views

MI5
Level 94: Supreme
  • 120577 Posts
  • 605 Topics
  • 18081 Solutions
Registered:

@GMF 

As I'm sure you know, there is no custom firmware for iPhones.

The only network influence is the carrier file, which should update automatically or which can usually be forced to update (if necessary) by connecting to iTunes.

However, my gut is saying it's due to you being new and O2's systems haven't caught up with everything yet.

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 13 of 20
752 Views

GMF
Level 2: Apprentice
  • 10 Posts
  • 1 Topics
  • 1 Solutions
Registered:
I did try the iTunes trick actually, but might be worth another go. I don’t know how O2 manages iOS devices, but Vodafone puts a configuration profile into Settings>General>Profile. I certainly don’t have one from O2. Do you?

I’ll give O2 as long as I can to sort things out within my cooling off period, because the damage is already done with regards to the credit check being on record.
Message 14 of 20
748 Views

MI5
Level 94: Supreme
  • 120577 Posts
  • 605 Topics
  • 18081 Solutions
Registered:

Not sure where it's stored but Settings >General >About and mine is O2 41.0 @GMF 

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 15 of 20
746 Views

GMF
Level 2: Apprentice
  • 10 Posts
  • 1 Topics
  • 1 Solutions
Registered:

Morning @MI5 and @O2John 

 

Having done my morning reboot of my phone, I can confirm that both elements are now correctly working!  Whether time, the great healer, or Cust Services fixed it, I can't be sure.   

 

I hope other customers experiencing this problem after a port-in have had their service fixed and get reassurance that they don't have a problem with their iPhones and that it can be resolved successfully.

 

However, @O2John , please send my apologies to your gut as it failed you on this one 😛

View solution in original post

Message 16 of 20
1,031 Views

Marjo
Former Staff
  • 7880 Posts
  • 468 Topics
  • 55 Solutions
Registered:

Great to hear it's working now @GMF ! Thanks for letting us know. thumbsup

 

COVID-19 support - Help and support from O2 during the lockdown
Access for You: Registration - Find out how to register for our Access for You service.
Just joined the community or thinking of registering? Check out this handy starter guide!
Have a query about your account? See if the My O2 how-to guide will help


If you'd like to take part, why not register? slight_smile
signature

Message 17 of 20
700 Views

SouthDownsMon
  • 1 Posts
  • 0 Topics
  • 0 Solutions
Registered:
Thank you all for your advice - it's been invaluable and so nice to have real humans helping rather than a cyber assistant.
I rebooted my new iphone SE and the O2 app said wifi calling had been successfully enabled. But it may take up to 24 hours to be activated so watch this space!
Message 18 of 20
650 Views

Hells1
Level 1: Joiner
  • 1 Posts
  • 0 Topics
  • 0 Solutions
Registered:

hi, i've just got a new ipone 11 and can't enable the Wifi calling... as i have terrible signal at home its so important i can have this on 😕

Message 19 of 20
258 Views

MI5
Level 94: Supreme
  • 120577 Posts
  • 605 Topics
  • 18081 Solutions
Registered:

@Hells1 

You need to ask customer services to enable it on your account and also check you have the iData bolt on active on your account.

Once that is done with customer services, you need to enable it in your MyO2. 

wifi on.PNG

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 20 of 20
251 Views