Showing results for 
Search instead for 
Did you mean: 

iOS 15 VoLTE issue

Level 1: Joiner
  • 2 Posts
  • 1 Topics
  • 0 Solutions

Recently upgraded to an iPhone 13 Pro from a XS. I no longer have the ability to chose which mobile network I wish to connect to, where I used to be able to disconnect from 4G and connect to 3G as it was stronger in my area. 
I've recently become a postman after leaving O2 as an employee and found I am unable to also turn off VoLTE/4G Calling. I cover an area of the northwest where VoLTE/4G calling is very ropey and calls very frequently become robotic and drop as a result of not having this option available. I’m not sure this is the right place for me to post this but can O2 update their carrier settings to allow users to turn this setting on/off as we were able to in previous iOS versions? 

Message 1 of 4

Level 94: Supreme
  • 127560 Posts
  • 614 Topics
  • 22191 Solutions


Unfortunately it's called progress........

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 2 of 4

Level 67: Unsung hero
  • 5677 Posts
  • 32 Topics
  • 1837 Solutions


I can still do this on IOS 15.3, so nothing to do with carrier settings, but it does look to have also have affected AT&T and some other networks globally, so looks like an OS restrictions. 

What is your carrier settings version?


Ignore the Honest Mobile, I am running in Dual Sim mode on my iPhone SE with Dev OS's



edited to add question

Current Phone: Sony XPeria Pro-I and Motorola Razr 5G
I also have a Planet Computers Gemini

I work in IT as an Enterprise Messaging and Collaboration Tools Administrator (Office 365, Slack and much much more) and manage hardware both Mobile and Desktop / laptop, my desk is a bit like PC World

We are all customers and dont have access to any o2 accounts

Message 3 of 4

  • 2 Posts
  • 1 Topics
  • 0 Solutions

Hi, thanks for the reply. 
I can see that you have the option available, as i believe it didn’t seem to be a problem using non 5G devices like yours, the iPhone SE. My partner has a 5G device in the iPhone 12 and also cannot change this setting.

 My carrier version is O2 48.0

Message 4 of 4