cancel
Showing results for 
Search instead for 
Did you mean: 

can't receive texts when using wifi

Irishman
Level 1: Joiner
  • 3 Posts
  • 1 Topics
  • 0 Solutions
Registered:

Hi,

I have a Google Pixel 5 and have just switched from a contract with 3 to pay as you go with O2.

However I can now not receive texts when connected to my home Wifi. Texts work correctly away from home but not at home. There was an option to enable texts via wifi/data when initially setting up but it seems to have disabled my ability to receive texts and I can't see where to reset this. I can send texts ok but not receive.

When switching networks, I kept the same phone but changed sims. 

Help?

Thanks,

Kevin

Message 1 of 6
157 Views
1 ACCEPTED SOLUTION

Accepted Solutions

MI5
Level 94: Supreme
  • 128216 Posts
  • 614 Topics
  • 22520 Solutions
Registered:

@Irishman 

You need to reset the default applications for sms messages in the messaging app.

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)

View solution in original post

Message 6 of 6
124 Views
5 REPLIES 5

Irishman
Level 1: Joiner
  • 3 Posts
  • 1 Topics
  • 0 Solutions
Registered:

forgot to add that I kept my old number.

Message 2 of 6
153 Views

MI5
Level 94: Supreme
  • 128216 Posts
  • 614 Topics
  • 22520 Solutions
Registered:

@Irishman 

O2 don't support sms over wifi on your phone yet.

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 3 of 6
151 Views

madasaf1sh
Level 68: Extraordinaire
  • 5924 Posts
  • 32 Topics
  • 1929 Solutions
Registered:

@Irishman 

 

with o2 you need to be on Pay Monthly, as o2 dont support WiFi Calling on PAYG and the same will probably when they roll out SMS over WiFi as well

Current Phone: Sony XPeria Pro-I and Motorola Razr 5G
I also have a Planet Computers Gemini

I work in IT as an Enterprise Messaging and Collaboration Tools Administrator (Office 365, Slack and much much more) and manage hardware both Mobile and Desktop / laptop, my desk is a bit like PC World

--
We are all customers and dont have access to any o2 accounts





Message 4 of 6
146 Views

Irishman
  • 3 Posts
  • 1 Topics
  • 0 Solutions
Registered:

Hi guys, thanks for the info.

I'm not sure why it gave me the option for sms over wifi if it's not something that O2 offer. 

The question is how do I deselect this now? As I can't receive texts while connected to wifi it feels like the phone is trying to do this even though it can't and thus blocking texts from coming in.

Any suggestions?

Kevin

Message 5 of 6
126 Views

MI5
Level 94: Supreme
  • 128216 Posts
  • 614 Topics
  • 22520 Solutions
Registered:

@Irishman 

You need to reset the default applications for sms messages in the messaging app.

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 6 of 6
125 Views