cancel
Showing results for 
Search instead for 
Did you mean: 

Wifi Calling

Wendy23
Level 1: Joiner
  • 1 Posts
  • 1 Topics
  • 0 Solutions
Registered:

Ive just moved to O2 and opened a monthly sim contract.  My phone is a Samsung Galaxy S7 Edge and i cant fjnd any way of enabling wifi calling.  It's  not on the connections menu.  Its vital I can get this  enabled due to health reasons that mean i need to be able to make a call at all times when my signal is not strong......can anyone help?

Message 1 of 3
180 Views
1 ACCEPTED SOLUTION

Accepted Solutions

MI5
Level 94: Supreme
  • 127071 Posts
  • 614 Topics
  • 21943 Solutions
Registered:

@Wendy23 

You need to ask O2 to enable it on your account first.

If you message O2 on Facebook (https://o2uk.co/O2CFB) , Twitter (https://o2uk.co/O2CTW) or Instagram (https://o2uk.co/O2CIG) , they should be able to help you with this.

After that, you can turn it on in your MyO2.

wifi on.PNG 

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)

View solution in original post

Message 2 of 3
176 Views
2 REPLIES 2

MI5
Level 94: Supreme
  • 127071 Posts
  • 614 Topics
  • 21943 Solutions
Registered:

@Wendy23 

You need to ask O2 to enable it on your account first.

If you message O2 on Facebook (https://o2uk.co/O2CFB) , Twitter (https://o2uk.co/O2CTW) or Instagram (https://o2uk.co/O2CIG) , they should be able to help you with this.

After that, you can turn it on in your MyO2.

wifi on.PNG 

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 2 of 3
177 Views

Spenny
Level 7: Part Timer
  • 106 Posts
  • 1 Topics
  • 10 Solutions
Registered:

You'll need to make sure you've enabled WiFi calling with o2.

O2 page below has the info

 

https://www.o2.co.uk/help/phones-sims-and-devices?page=device/samsung/galaxy-s7-android-n/topic/sett...

Motorola G100 128GB
Message 3 of 3
174 Views