cancel
Showing results for 
Search instead for 
Did you mean: 

Unknown callers since roaming

SK92
Level 1: Joiner
  • 1 Posts
  • 1 Topics
  • 0 Solutions
Registered:

Hi, 

 

I got my S23+ on September 15th and it was fine.

 

Then on 21st September I went to Czech Republic with roaming enabled and since then incoming calls show as "unknown number" except for when I'm connected to WiFi (I can see the little WiFi logo in my call log next to the ones that show a number, too)

 

I thought it might be temporary while I was away but the problem has persisted since.

 

Looking online the suggestions seem to be:

- turn off 4g calling and WiFi calling, which I've done but it just means even more calls are unknown number 

- reset all network settings in Android

- contacted O2 support to ask for the CLI bolt on, they've said it's already enabled 

 

I'm waiting for O2 to get back to me for ages and at this point I'm convinced even they don't know what to do 

 

So I'm wondering if any other customers have had a similar issue and have they managed to resolve it?

Message 1 of 2
267 Views
1 REPLY 1

pgn
Level 74: Whizz kid
  • 34653 Posts
  • 217 Topics
  • 1533 Solutions
Registered:

One way that has fixed this is to get O2 to add a bolt-on, free, called CLI, or CALLER LINE IDENTITY, Presentation bolt-on.

Another more drastic route is for you to get O2 to reset your account completely on their side - it means you may be without any voice service for a few hours. Call 202 or reach out to O2 via Social Media, link below has Twitter, Facebook and Instagram access links. Good luck @SK92.

Message 2 of 2
250 Views