Welcome to the O2 Community

Has your question already been answered? See the community FAQ's

Pay Monthly

Reply
Highlighted
Anonymous
Posts: 0

Phoning a UK mobile from the USA

Hello all,

My friend has been trying to phone me from the USA on her mobile to my mobile here in the UK.

She has tried

+44 then my mobile number minus the 0

and

011 +44 then my mobile number minus the 0

Neither of these seem to be connecting, I am sure one of these are correct.

I am able to call her using my phone book list with no problems at all.

Does anyone have any ideas why her calls to me are not connecting Smiley Indifferent
Highlighted
Anonymous
Posts: 0

Phoning a UK mobile from the USA

just guessing but it might be 01144codenumber ie 011447755757575
Highlighted
Anonymous
Posts: 0

Phoning a UK mobile from the USA

Sorry not quite sure what you mean by codenumber?
Highlighted
Anonymous
Posts: 0

Phoning a UK mobile from the USA

the phone number
Highlighted
Anonymous
Posts: 0

Phoning a UK mobile from the USA

No she just dials +44 and then the phone number without the initial 0.

However she needs to have roaming enabled and she needs to be roaming on a network which allows direct dialling. Get her to check the calling from abroad section of the website. In particular the Before You Go section.

If she is following that procedure and has everything set up then there is a fault somewhere.
Highlighted
Anonymous
Posts: 0

Phoning a UK mobile from the USA

Thanks for the replies.

Yes apparently in the USA she should be able to just dial using her phone book, although she has also tried keying in the number manually, and she did just the obvious +44 then the mobile number without the 0 when she keyed it in manually, but she just keeps getting a message saying something along the lines of "cannot complete the call".

I am starting to wonder about the roaming thing, she didn't set up roaming prior to going, to be honest I didnt realise you had to. The other odd thing is I can phone her no problem direct from my phone book.

Is roaming defaulted to off, and you have to get it activated??