cancel
Showing results for 
Search instead for 
Did you mean: 

Charger not recognised?

Clare748
Level 1: Joiner
  • 3 Posts
  • 1 Topics
  • 0 Solutions
Registered:
Hi!
Since I’ve updated my iPhone 6s sometimes when I try to charge it, it says ‘this device cannot be recognised’. I’ve cleaned the port and turned my phone off and on but it still won’t charge properly and my phone is only 2 years old. Anyone have any advice for this? Thank you.
Message 1 of 6
1,654 Views
5 REPLIES 5

MI5
Level 94: Supreme
  • 123832 Posts
  • 611 Topics
  • 20043 Solutions
Registered:

@Clare748 that usually happens with a non Apple charger or cable.

Only use genuine or approved accessories.

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 2 of 6
1,651 Views

Clare748
Level 1: Joiner
  • 3 Posts
  • 1 Topics
  • 0 Solutions
Registered:
Sorry forgot to say that’s the original Apple charger! I’ve tried it with other Apple chargers too and the same thing happens.
Message 3 of 6
1,647 Views

Bambino
Level 74: Whizz kid
  • 18721 Posts
  • 914 Topics
  • 2307 Solutions
Registered:

@Clare748  Sounds like you need to book an appointment at an Apple store.

I DO NOT WORK FOR O2



Funniest-Thread-2
Message 4 of 6
1,644 Views

MI5
Level 94: Supreme
  • 123832 Posts
  • 611 Topics
  • 20043 Solutions
Registered:

I would suspect a damaged or dirty charging port then @Clare748  

Is your software upto date?

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 5 of 6
1,636 Views

Clare748
Level 1: Joiner
  • 3 Posts
  • 1 Topics
  • 0 Solutions
Registered:
I’ve only had the problem since I updated to the lastest software and I’ve cleaned the port. Really hoping the port isn’t damaged but it seems like the only reason why it won’t charge.
Message 6 of 6
1,630 Views