cancel
Showing results for 
Search instead for 
Did you mean: 

Android 10, Popup notifications, S10, Whatsapp

Tania28445
Level 1: Joiner
  • 7 Posts
  • 1 Topics
  • 0 Solutions
Registered:

Installed new Android update from O2 on my S10 last night  - the blurb for the update said it was a "security update" so I wasn't expecting any settings to change! Unfortunately, it was more than just security update, it took phone from Android 9 to Android 10.  Now regretting updating, since Whatsapp "popup notifications are no longer available in your version of android" !!

 

I cannot currently find a workaround, but will keep looking. Am pretty tech savvy but not so much that I would risk downgrading (and this would probably void my warranty which I certainly don't want to do!).

Anyone else had this problem and have some suggestions as to a fix, other than wait and hope a further release fixes the problem?(I know pixel users have had it for some time). 

Message 1 of 11
12,444 Views
10 REPLIES 10

MI5
Level 94: Supreme
  • 120693 Posts
  • 605 Topics
  • 18166 Solutions
Registered:

@Tania28445 

It may sound obvious but have you checked for an update to your WhatsApp app ?

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 2 of 11
12,365 Views

MI5
Level 94: Supreme
  • 120693 Posts
  • 605 Topics
  • 18166 Solutions
Registered:
Also, go to settings >advanced features >smart popup >and activate WhatsApp.
I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 3 of 11
12,359 Views

Tania28445
Level 1: Joiner
  • 7 Posts
  • 1 Topics
  • 0 Solutions
Registered:

Hi, yes, ran all updates after updating phone. I believe it's an Android problem not an app problem.

Message 4 of 11
12,357 Views

jonsie
Level 94: Supreme
  • 85248 Posts
  • 591 Topics
  • 4463 Solutions
Registered:

If there is no update available check the version you have. I have just downloaded the 2.20.13 apk which gives you dark mode. Pop ups working fine.

Message 5 of 11
12,356 Views

MI5
Level 94: Supreme
  • 120693 Posts
  • 605 Topics
  • 18166 Solutions
Registered:

@Tania28445 

See my post just above your last reply.

Also, Go to Settings app > Apps & notifications > See all apps. Find WhatsApp. Tap the app’s name, and then tap Notifications. Tap under Show notifications, and on the next screen, make sure you have the Pop-up screen enabled.

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 6 of 11
12,354 Views

Tania28445
Level 1: Joiner
  • 7 Posts
  • 1 Topics
  • 0 Solutions
Registered:

Already on. I'm talking about the popup notification similar to the one that's on iphone. Not the tiny little notification that you have to expand. Looks like this:

Whatsapp pop up pre Android10.jpg

Message 7 of 11
12,353 Views

MI5
Level 94: Supreme
  • 120693 Posts
  • 605 Topics
  • 18166 Solutions
Registered:

@Tania28445 

Final thought from me for for now....

Go to Settings app > App & notifications > Advanced > Special app access > Adaptive notifications > select None.

If that doesn't help, you should maybe contact WhatsApp or, as you say, wait for an Android update to fix it.

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 8 of 11
12,350 Views

Tania28445
Level 1: Joiner
  • 7 Posts
  • 1 Topics
  • 0 Solutions
Registered:

@MI5 wrote:

@Tania28445 

See my post just above your last reply.

Also, Go to Settings app > Apps & notifications > See all apps. Find WhatsApp. Tap the app’s name, and then tap Notifications. Tap under Show notifications, and on the next screen, make sure you have the Pop-up screen enabled.


There is no option for "pop up screen" under notifications and in the "in app notifications " the pop up option is greyed out. Screenshot_20200123-081846_WhatsApp.jpg

Message 9 of 11
12,347 Views

Tania28445
Level 1: Joiner
  • 7 Posts
  • 1 Topics
  • 0 Solutions
Registered:

Did that as well. 


@MI5 wrote:

@Tania28445 

Final thought from me for for now....

Go to Settings app > App & notifications > Advanced > Special app access > Adaptive notifications > select None.

If that doesn't help, you should maybe contact WhatsApp or, as you say, wait for an Android update to fix it.


 

Message 10 of 11
12,346 Views