cancel
Showing results for 
Search instead for 
Did you mean: 

Internet not working on mobile

Rebecca123
Level 1: Joiner
  • 3 Posts
  • 1 Topics
  • 0 Solutions
Registered:

Hi there, looking for advice with regards to my Samsung S9 mobile. For some reason I can access any website on my device but for some reason my mobile is not allowing me to actually use he webiste or the internet properly. For expample, I tried to purchase something online but when clicking on the menu nothing happens. it sometimes even says "please enable JavaScript" but cannot find how to do that.

 

Any advice would be very much appreciated. Thank you. 

Message 1 of 6
354 Views
1 ACCEPTED SOLUTION

Accepted Solutions

MI5
Level 94: Supreme
  • 128153 Posts
  • 614 Topics
  • 22500 Solutions
Registered:

@Rebecca123 

Try downloading a different browser such as chrome, edge or Firefox. 

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)

View solution in original post

Message 2 of 6
349 Views
5 REPLIES 5

MI5
Level 94: Supreme
  • 128153 Posts
  • 614 Topics
  • 22500 Solutions
Registered:

@Rebecca123 

Try downloading a different browser such as chrome, edge or Firefox. 

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 2 of 6
350 Views

Rebecca123
Level 1: Joiner
  • 3 Posts
  • 1 Topics
  • 0 Solutions
Registered:
Thank you! Chrome worked

I just tried to use an app that i downloaded but that too is also asking to enable JavaScript.

"Sorry, you need to enable javascript in your device settings for this application to function."

Is there any way doing so via settings?
Message 3 of 6
316 Views

MI5
Level 94: Supreme
  • 128153 Posts
  • 614 Topics
  • 22500 Solutions
Registered:

@Rebecca123 

  1. Open Chrome.
  2. At the top right, click More More  Settings.
  3. At the bottom, click Advanced.
  4. Under 'Privacy and security', click Content settings.
  5. Click JavaScript.
  6. Turn on Allowed (recommended).
I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 4 of 6
314 Views

Rebecca123
Level 1: Joiner
  • 3 Posts
  • 1 Topics
  • 0 Solutions
Registered:
Thank you! Found it but it was already on 'Allowed' but still cannot access app which is frustrating
Message 5 of 6
312 Views

MI5
Level 94: Supreme
  • 128153 Posts
  • 614 Topics
  • 22500 Solutions
Registered:

@Rebecca123 

Check your general phone settings for it too.

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 6 of 6
306 Views