cancel
Showing results for 
Search instead for 
Did you mean: 

no number syndrome

MartinIP
Level 1: Joiner
  • 2 Posts
  • 1 Topics
  • 0 Solutions
Registered:

What the hell is going on with 02's new sim cards? I have had about 5 new 4g sim cards and used them with a brand new mobile and every incoming phone call was "no number" even from my contacts list? I eventually sent the new phone back and put the sim card into my ancient Nokia phone that has never given me a problem and guess what....all incoming phone calls are "no number" I have reset the phone and activated yet another new 02 sim card and the problem still persists.So I have no idea who is calling me and if I miss the call I have no idea who called to phone them back......SO ANNOYING

Message 1 of 16
1,981 Views
15 REPLIES 15

jonsie
Level 94: Supreme
  • 93262 Posts
  • 610 Topics
  • 6985 Solutions
Registered:

Also customers who upgraded or changed tariff have had this issue

Why did it take a customer reporting back to let us know about this?

There have been hundreds with this problem

Is this a new fix

Why didn't the community managers tell us what the fix was?

We are trying to answer customers with one arm tied behind our back!

Message 11 of 16
479 Views

Enlli
Level 66: Unequalled
  • 7008 Posts
  • 51 Topics
  • 1573 Solutions
Registered:

So the customer has to go through the trauma of ringing an already overburdened customer services. Judging by posts the agents are likely not aware of the CLI Presentation Facility, certainly customers would not know what to ask for unless they come here. Most will be told it will be fixed in 24 hours!

So why is something that has been standard for years, suddenly gone.AWOL?

 

This is not O2 and we are all customers here similar to yourself and cannot answer account type queries.
Message 12 of 16
473 Views

Kosmos5457
Level 2: Apprentice
  • 31 Posts
  • 3 Topics
  • 0 Solutions
Registered:

As it turned out, seems a relatively simple fix that anyone would expect a level 1 customer service person to be able to say to the customer, yes, I know what that issue could be and to look at adding CLI Presentation Facility to account. It is also right that this never used to be there or needed on my account. 

It was only after an upgrade of iPhone from XS to 14 Pro, with a 5G SIM swap that I started seeing the issue. When I took to the community and read reports of people with Android based devices having same problem, I then realised this isn't my device, it can't be the SIM either, look how many now having this issue and also consider that people who are having this issue have also made tariff changes etc. 

 

When the best they can suggest is that you give it 24hrs, or you reset your phone to factory defaults, or that you do a SIM swap, the issue being account related afterall is a massive oversight. 

I was unimpressed going through Customer Services. I'd sent emails to CEO level to get this addressed. I had network engineers take a look, I'd asked for disconnect and reconnect of my number to bring it all back. Coincidently, someone reached me at a point where the issue miraculously resolved itself. I thought it was something they'd done in the background with my number, with my account. I didn't expect to see the obvious addition of CLI Presentation Facility under my bolt-ons and that be actual fix. 

This has dragged on months for many. Hopefully O2 are working on it internally and communicating this issue and the resolution with their frontline staff. 

It could save people a lot of trouble. 

Message 13 of 16
454 Views

gmarkj
Level 66: Unequalled
  • 12237 Posts
  • 95 Topics
  • 1139 Solutions
Registered:

Not so in this case @Dave-O2 - seems as though reporting a sim lost and being issued a new one caused it:

https://community.o2.co.uk/t5/Tech-Support/CLI-Not-Working-On-Replacement-SIM-Card/m-p/1656814#M3991... 

Please note, this is not customer services and we cannot access your account. Do not publish personal details (email, phone number, bank account).


Link to our guide on how to contact them can be found here

Message 14 of 16
447 Views

Hoping--
  • 1 Posts
  • 0 Topics
  • 0 Solutions
Registered:

Virgin migrated to O2. Changed phone. All calls from unknown. Cli Presentation active. Called 202, said they would activate Cli. Told me to reset network connections, reboot, wait up to 24 hours. No joy so fay about 7 hours to go...

Message 15 of 16
260 Views

Enlli
Level 66: Unequalled
  • 7008 Posts
  • 51 Topics
  • 1573 Solutions
Registered:

@Hoping-- Go into your bolt ons in My O2 and check that CLI Presentation has been added

1000008402.jpg

This is not O2 and we are all customers here similar to yourself and cannot answer account type queries.
Message 16 of 16
239 Views