cancel
Showing results for 
Search instead for 
Did you mean: 

Wifi calling Xperia 1 not working

ATNeuromonkey
Level 1: Joiner
  • 6 Posts
  • 1 Topics
  • 0 Solutions
Registered:
I recently got the Xperia 1 from O2 and for a couple of days the WiFi calling was working now it is not. I have done many restarts of the phone, checked the firmware, but have had no luck getting it back i.e. there is no options in the networks settings available for it anymore. Can anyone help?
Message 1 of 34
5,725 Views
33 REPLIES 33

BLUEOCEAN
  • 6 Posts
  • 0 Topics
  • 0 Solutions
Registered:

I seem to have inadvertently fixed this issue on my Sony XZ1

 

Within the phone app, I went to 'Settings' | Calls | 'Accessibility'

 

I noticed TTY mode was set to 'off'. I set it to 'TTY full' and rebooted the phone.

 

Within the phone app, I can now see 'Wifi Calling' as an option within 'Settings' | Calls |

 

I'd be interested to know if this works for anyone else?

Message 21 of 34
1,708 Views

MI5
Level 94: Supreme
  • 127517 Posts
  • 614 Topics
  • 22167 Solutions
Registered:
TTY is part of the accessibility features for deaf or hard of hearing, so I doubt it's a requirement for wifi calling in all honesty.
I suspect it's just coincidental to O2 fixing the issue on their servers.
I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 22 of 34
1,707 Views

BLUEOCEAN
Level 1: Joiner
  • 6 Posts
  • 0 Topics
  • 0 Solutions
Registered:

I believe you are quite correct @MI5 .  Just turned TTY off and still have wifi calling.  Must have been pure coincidence.  Many thanks

Message 23 of 34
1,699 Views

ATNeuromonkey
Level 1: Joiner
  • 6 Posts
  • 1 Topics
  • 0 Solutions
Registered:
I am still having the issue and no one can provide a working solution! I get intermittent wifi calling and it has now been 2 months since I got the phone. Customer service never has an answer for me and none of these posted solutions have provided an answer! @Chris_K
Message 24 of 34
1,673 Views

viridis
Level 56: Guvnor
  • 13480 Posts
  • 100 Topics
  • 307 Solutions
Registered:
Mines gone again...
Message 25 of 34
1,655 Views

Foddersin
Level 3: Thinker
  • 68 Posts
  • 0 Topics
  • 0 Solutions
Registered:
So I now have an Xperia 1 but not directly from O2.
I have flashes it with the O2 firmware and the issue does appear to be more network sided than software on the phone.
Very intermittent connection to WiFi and 4G calling, will connect but that is not always the case and have to reboot multiple times to get it back.
Kindest Regards,
Andrew.
Samsung Galaxy S10+ on O2 UK
Nokia 1 Plus on O2 UK
Message 26 of 34
1,632 Views

jonsie
Level 94: Supreme
  • 86972 Posts
  • 594 Topics
  • 5122 Solutions
Registered:

This is definitely a network issue. So many people have this problem with O2 aand unless all these customers have the same software issue it points to a network fault.

Perhaps @viridis knows whether Sony have said there is a software fault on the X1?

2020-Awards-jonsie5695219-2




O2 Social Media

SM IconsTwitter

Instagram

Facebook




Message 27 of 34
1,623 Views

viridis
Level 56: Guvnor
  • 13480 Posts
  • 100 Topics
  • 307 Solutions
Registered:
No fault that I'm aware of, and I have asked about this.
Message 28 of 34
1,622 Views

jonsie
Level 94: Supreme
  • 86972 Posts
  • 594 Topics
  • 5122 Solutions
Registered:

@viridis wrote:
No fault that I'm aware of, and I have asked about this.

Unfortunately as I was afraid. 

2020-Awards-jonsie5695219-2




O2 Social Media

SM IconsTwitter

Instagram

Facebook




Message 29 of 34
1,606 Views

viridis
Level 56: Guvnor
  • 13480 Posts
  • 100 Topics
  • 307 Solutions
Registered:
Still on and mostly off on this, could've done with it today as local mast is fubard
Message 30 of 34
1,591 Views