cancel
Showing results for 
Search instead for 
Did you mean: 

Sony Xperia Z

Anonymous
Not applicable

My Xperia keeps failing to send emails through the gmail app.  It's really annoying and doesn't seem to matter whether it's connected by the O2 network or wifi.

 

Just now, however, it's added a new trick, and is failing to send photoMMS messages too.

 

I've tried rebooting the phone, and it doesn't seem to make a difference.  Last time it did this with the email it decided to send them 2 days later, and after they were deleted from the outbox (apparently unsent).

 

Anyone having similar problems, or is my phone just a dodgy one that needs replaced?

Message 1 of 4
2,968 Views
1 ACCEPTED SOLUTION

Accepted Solutions

AlignedChaos
Level 9: Fired up
  • 77 Posts
  • 13 Topics
  • 14 Solutions
Registered:

I had a similar problem with GMail not recieving.

 

It turns out, for some reason, that GMail sync keeps turning off in Google Services (Settings/Accounts/Google/(your-email-address).  Infact a check just now shows that GMail is again unticked.

Ticking it should resolve the issue, but for how long, who knows.

View solution in original post

Message 3 of 4
2,768 Views
3 REPLIES 3

Anonymous
Not applicable
Hi.


Have you tried another e mail app instead if the stock one.

For example I used k9 on the z1 when I reviewed the phone and it worked fine.

Ensure you have set your e mail to pop3 or IMAP.

Ref mms.

Send ACTIVE To 2020 save the settings and turn your phone off and on if the issue continues.

Sometimes just turning the phone off and on helps too.

Ask O2 by phone call to Cs to re provision your account for mms as this is known to help with also Taking your sim out and cleaning it.

Checking your service status for issues with your masts

http://status.o2.co.uk


Sometimes it's congestion we think that causes delayed messages.
Message 2 of 4
2,964 Views

AlignedChaos
Level 9: Fired up
  • 77 Posts
  • 13 Topics
  • 14 Solutions
Registered:

I had a similar problem with GMail not recieving.

 

It turns out, for some reason, that GMail sync keeps turning off in Google Services (Settings/Accounts/Google/(your-email-address).  Infact a check just now shows that GMail is again unticked.

Ticking it should resolve the issue, but for how long, who knows.

View solution in original post

Message 3 of 4
2,769 Views

Anonymous
Not applicable
Thanks, I'll give that a shot.
Message 4 of 4
2,762 Views