cancel
Showing results for 
Search instead for 
Did you mean: 

Unknown Caller Issue - Receiving Calls From Contacts

Kosmos5457
Level 2: Apprentice
  • 31 Posts
  • 3 Topics
  • 0 Solutions
Registered:

Hello O2 Community,

 

I've been recently troubled by some issue where when I'm receiving phone calls from contacts listed in my iPhones contacts, instead of my iPhone stating their name, it says Unknown Caller. This is particularly unhelpful, especially if out in the car so using CarPlay, or even when taking a glance at my Apple Watch and seeing the same issue. 

This has only started happening since I migrated from my old iPhone XS to iPhone 14 Pro and in the past month or so is when I upgraded. At this point, as I was moving from an old 4G SIM to a new 5G SIM, I was requiring a SIM swap. 

I've not seen any other issues and have also spoken to Apple about this. I did mention that I hadn't yet followed up with network provider. 

The interesting thing is that this appears to be intermittent. It doesn't happen on every call. I don't know if it is happening in certain places but not others. I don't think I've seen the issue at home at all such as when I may be on O2 WiFi Calling for example. I may have seen it in areas I think, where I have 4G reception but again, not entirely certain of that. 

When I check phone call history on iPhone itself after an Unknown Caller issue, it displays also as Unknown Caller. This suggests to me that the issue is with something on the phone or the service.

 

I had wondered also if deleting or editing contact may help. It's just that it is intermittent, so now thinking it is more the service that is the issue with receiving calls, that not always the caller ID is being sent to me so I can identify who is calling me. 

I read some more last night into this issue. There have been suggestions of switching off 4G calling but I don't see option to do that. I understand o2 may have removed this option with carrier update and toggled this setting off but it does not display on my phone so I can confirm.

 

I spoke with o2 support yesterday and they said no issues with service for me. It wasn't looked into or investigated further. It was just said yeah all is fine. I would appreciate having someone on the end of the phone that can escalate if necessary and do some deeper checks with network. 

Message 1 of 28
8,124 Views
27 REPLIES 27

Kosmos5457
Level 2: Apprentice
  • 31 Posts
  • 3 Topics
  • 0 Solutions
Registered:

Just to add to what I said above, I was reading other community posts that suggest others are experiencing these issues. More recent as well. 

See following threads:

https://community.o2.co.uk/t5/Apple/Incoming-calls-show-as-Unknown/td-p/1621927

https://community.o2.co.uk/t5/Tech-Support/Unknown-Caller-ID-for-Contacts/td-p/1632990

 

 

 

 

 

Message 2 of 28
5,359 Views

Cleoriff
Level 94: Supreme
  • 123977 Posts
  • 828 Topics
  • 7500 Solutions
Registered:

@Kosmos5457 

A new sim has fixed this issue for some as has turning off 4G calling.

I will tag an account advisor @O2Ryan for you. He is rostered to be on duty at 8am tomorrow. There is no guarantee he will be on though as there appears to be issues with the 'rota'.

Best of luck👍

Veritas Numquam Perit

Girl in a jacket
Message 3 of 28
5,355 Views

Kosmos5457
Level 2: Apprentice
  • 31 Posts
  • 3 Topics
  • 0 Solutions
Registered:

Thank you @Cleoriff. I really hope that this issue can be resolved. I have found possible solutions on here but unfortunately the one suggesting I turn off 4G calling, I don't see that as an option anywhere on my iPhone 14 Pro. I recall seeing it when I had iPhone XS but that was a while ago. 

Message 4 of 28
5,351 Views

pgn
Level 75: Digital Don
  • 37116 Posts
  • 238 Topics
  • 1690 Solutions
Registered:
Message 5 of 28
5,344 Views

Kosmos5457
Level 2: Apprentice
  • 31 Posts
  • 3 Topics
  • 0 Solutions
Registered:

I've turned Wi-Fi Calling off and back on. Awaiting some time to see if that helps. Convinced this is an intermittent issue though and problem on carrier side since SIM swap. I see no option to turn off 4G calling. In Mobile Data, there is 5G Auto, 5G and 4G setting though. Set mine to 5G now and Roaming is on. 

Message 6 of 28
5,341 Views

pgn
Level 75: Digital Don
  • 37116 Posts
  • 238 Topics
  • 1690 Solutions
Registered:

The 5G Auto, 4G, 3G thing is not the same, it is the "preferred network type" - here is the pixel 6a equivalent screen, note at the bottom, as I am in a roaming area with no 5G, I have it set to 4G.

My green squiggles talk to "4G Calling".

1000004359.png

 

Message 7 of 28
5,335 Views

Kosmos5457
Level 2: Apprentice
  • 31 Posts
  • 3 Topics
  • 0 Solutions
Registered:

I understand that it is a different setting, though it was the only setting I could find which may be considered remotely close to what I was looking for.

 

I gave o2 a call earlier, their advice was going into Settings, then General, Reset Network Settings under the Reset options. I do not know yet if that as at all helped me with this issue. I think only time will tell.

 

I had a look at Carrier settings version on my iPhone and also checked my wife's iPhone. I noticed we have same version of Carrier settings, we are on same iOS version which is 16.5.1( c ). This has been going on since the first 16.5.1 update in any case and that is the version I started using with my iPhone 14 Pro. I'd updated to 16.5.1 prior to switching iPhones then done a restore from backup, from the local copy on the Mac, figuring it would be much quicker to restore from local backup, than from iCloud.

 

It doesn't seem that this issue is exclusive to iPhones though. I hope it is something carrier side if this issue hasn't resolved by itself.

 

O2 switched off 4G calling a while back if not mistaken? So maybe that is why I don't see that setting now. I am sure my wife has it enabled on her iPhone, which is with O2 and she has an iPhone XS, no issues.

Message 8 of 28
5,319 Views

pgn
Level 75: Digital Don
  • 37116 Posts
  • 238 Topics
  • 1690 Solutions
Registered:

There was a security bug in Android back in May or so, to which the advice was to disable 4G Calling/VoLTE until vendors could get an update rolled out that addressed the issue. 

O2 sell 4G Calling as necessary in geographies where 3G has been turned-off - yet those in PAYG do not get it, and need to use an app, eg. WhatsApp, for calling and messaging in such places, if you are an O2 Roaming Customer.

From O2: 

4G Calling (also called Voice over LTE or VoLTE) lets you make calls using our fast 4G network, for a clearer voice call. If 4G Calling is available, you can just dial the number you want to call like normal. You can check 4G Calling coverage using our coverage checker. They're two great ways to stay connected with O2.

Message 9 of 28
5,312 Views

Kosmos5457
Level 2: Apprentice
  • 31 Posts
  • 3 Topics
  • 0 Solutions
Registered:

It is unclear if this is causing me an issue or not. As I say, only option I had was disable WiFi Calling, though I want it enabled. Sometimes signal is poor in the house but not all the time. In my area, 3G and 4G coverage is good outdoors and works most places I go such as when going to work. There are not too many spots with no coverage at all and I'll see either 3G or 4G consistently in places there is coverage. 

I am wondering if this issue happens specifically on 4G though. I probably need to be more aware of what coverage I have at the time I'm receiving calls.

 

Do you know of anything I should be asking O2 can do on their end? I'm convinced if I tried another network and SIM in my iPhone, that this wouldn't happen.

 

Not quite suggesting it is SIM card itself though maybe another SIM swap is an option. I'd rather try those things than go for a lets wipe phone and start over. I'd be rather annoyed if I went for the more painful options and found it is still not resolved. 

I take some comfort in knowing that it isn't just me with this issue. Given how this seems to be intermittent but is happening to various people, they can't all have bad hardware when otherwise their device functions. 

Message 10 of 28
5,308 Views