cancel
Showing results for 
Search instead for 
Did you mean: 

iMessage issue - not able to add in My Number

rob4465
Level 1: Joiner
  • 6 Posts
  • 2 Topics
  • 0 Solutions
Registered:

Hi all,

 

I have an issue with my iMessage where most of the people I message with iPhones show up as 'green messages' - so they are being sent as SMS etc.

 

Now, I have recently moved to an eSIM and notice that if I go to Settings - Messages - iMessage - Send & Receive my Apple ID email address is available but my phone number does not show as it did prior to moving to an eSIM.

 

I'm pretty sure that this lack of being able to add in my own phone number and it not showing up within iMessage is the cause of green messages, rather than blue iMessages.

 

I wondered if anyone could clarify whether this is just due to using an eSIM on the O2 network? I have tried everything else, Network reset, switching iMessage / FaceTime off and back on again.

 

Thanks in advance for any thoughts.

 

Rob

Message 1 of 11
1,315 Views
10 REPLIES 10

MI5
Level 94: Supreme
  • 127533 Posts
  • 614 Topics
  • 22169 Solutions
Registered:

@rob4465 

Is your number showing in Settings >Phone >My Number?

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 2 of 11
1,178 Views

rob4465
Level 1: Joiner
  • 6 Posts
  • 2 Topics
  • 0 Solutions
Registered:

Hi, no - nothing showing up. I can type a number into the box that comes up and click on Save but it doesn't do anything. I'm assuming this is the cause of the issue.

Thanks,

Rob

Message 3 of 11
1,160 Views

MI5
Level 94: Supreme
  • 127533 Posts
  • 614 Topics
  • 22169 Solutions
Registered:

@rob4465 wrote:

I'm assuming this is the cause of the issue.


Yes it will be the issue.

I'll have a look to see how to fix it for you.

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 4 of 11
1,152 Views

MI5
Level 94: Supreme
  • 127533 Posts
  • 614 Topics
  • 22169 Solutions
Registered:

@rob4465 

Try this:

Go to Settings – Apple ID – Name, Phone Numbers, E-mail, and look at the “Reachable At” section. Make sure that the number you want to use for iMessage and FaceTime is listed. If it’s blank or incorrect, change/add it.

Next, go to Settings – FaceTime, and look under “You Can Be Reached by FaceTime At”. If the number you want to use isn’t selected (ie, doesn’t have a checkmark beside it,) tap on it to activate it.

Finally, go to Settings – Messages – Send and Receive, and look under “You Can Receive iMessgaes To and From.” Again, if the number you want to use doesn’t have a checkmark beside it, tap on it to activate it.

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 5 of 11
1,148 Views

rob4465
Level 1: Joiner
  • 6 Posts
  • 2 Topics
  • 0 Solutions
Registered:

Thanks very much for the suggestions. I have discovered that by going to Apple ID – Name, Phone Numbers, E-mail the contactable at part DOES list my phone number and Apple ID.

 

Looking at FaceTime the only thing listed is my Apple ID (no phone number).

 

Same applies for Messages - Send & Receive - Apple ID shows, however no phone number.

 

Not sure if it will be easier to reset my phone and start from scratch?

 

Many thanks,

 

 

Message 6 of 11
1,146 Views

MI5
Level 94: Supreme
  • 127533 Posts
  • 614 Topics
  • 22169 Solutions
Registered:

@rob4465 

A reset may be an option but I'd check the tips here first. 

https://toomanyadapters.com/imessages-switch-sim-cards/#:~:text=For%20them%2C%20iMessage%20and%20Fac....

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 7 of 11
1,140 Views

Anonymous
Not applicable
I had the same problem on EE. After a reset of network settings. Phone off & a fresh download of network details, it was sorted.
Message 8 of 11
1,128 Views

rob4465
Level 1: Joiner
  • 6 Posts
  • 2 Topics
  • 0 Solutions
Registered:
Thanks very much for your assistance with this. In the end I did a complete reset / wipe of my phone and restored from my last iCloud backup. Upon doing this my number appeared as did the ability to select my number within iMessage and FaceTime.
Message 9 of 11
1,111 Views

rob4465
  • 6 Posts
  • 2 Topics
  • 0 Solutions
Registered:
Thanks very much for your assistance. I did try resetting Network settings without any luck. In the end I did a complete reset / wipe of my phone and restored from backup. This has done the trick albeit a last resort!
Message 10 of 11
1,111 Views