cancel
Showing results for 
Search instead for 
Did you mean: 

My number comes up as private when I call my contacts

broccoliscorpio
Level 1: Joiner
  • 1 Posts
  • 1 Topics
  • 0 Solutions
Registered:

 

I've recently come to O2 from Giffgaff and ported my number across. However I noticed that when I call my contacts, my number comes up as private. I'm on a OnePlus 5.

 

I contacted Live chat with O2 and tried the suggestions below which didn't work:

  • restarting the device
  • removing the sim then inserting it back again
  • Changing the settings in Calls > Settings > Call settings > Additional settings. Tapping Caller ID, then select from the following: Show number.

I was told it was a technical issue with the handset, but this has never happened with my previous sim cards on my OnePlus 5.

 

I have requested a SIM to try to see if that fixes it, but I was wondering if anyone had any advice on how to fix this?

 

Thank you!

 

 

Message 1 of 2
128 Views
1 REPLY 1

jonsie
Level 94: Supreme
  • 86609 Posts
  • 594 Topics
  • 4999 Solutions
Registered:

Dialer - Settings - Call settings - Select SIM - Additional settings - Caller ID

Otherwise try the new sim

 

 

 

Message 2 of 2
121 Views