cancel
Showing results for 
Search instead for 
Did you mean: 

Samsung S20+ Wifi Calling Disappeared

Portlanders
Level 2: Apprentice
  • 17 Posts
  • 3 Topics
  • 0 Solutions
Registered:

Had an update on 12th Dec, since then noticed the wifi calling option has dissapeared and not turned on, which i need from home as i have no signal without it..... and i'm working from home! 

My phone is dual sim and also have a 3 sim card in it for emergencies. 

When i turn on the 3 sim, the wifi calling option appears, as does the VoLTE option. 

The o2 sim doesn't show any wifi calling option, and the VoLTE option is greyed out in the off position. 

This tells me it's an O2 issue.... but i don't know how to inform O2, as it directs me here. 

I've checked My O2 and wifi calling is turned on in my account.

Can anyone help please? 

Message 1 of 7
3,827 Views
1 ACCEPTED SOLUTION

Accepted Solutions

MI5
Level 94: Supreme
  • 120831 Posts
  • 605 Topics
  • 18249 Solutions
Registered:

@Portlanders 

You need to turn off phone and remove O2 sim.

Restart the phone and when it has fully booted up, replace the O2 sim.

You will then have the wifi calling options.

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)

View solution in original post

Message 2 of 7
3,820 Views
6 REPLIES 6

MI5
Level 94: Supreme
  • 120831 Posts
  • 605 Topics
  • 18249 Solutions
Registered:

@Portlanders 

You need to turn off phone and remove O2 sim.

Restart the phone and when it has fully booted up, replace the O2 sim.

You will then have the wifi calling options.

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)

View solution in original post

Message 2 of 7
3,821 Views

Portlanders
Level 2: Apprentice
  • 17 Posts
  • 3 Topics
  • 0 Solutions
Registered:

Genius! 

Thank you so much, that sorted it. 

Many Thanks. 

Message 3 of 7
3,815 Views

MI5
Level 94: Supreme
  • 120831 Posts
  • 605 Topics
  • 18249 Solutions
Registered:
You're welcome
I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 4 of 7
3,811 Views

BSB1
Level 1: Joiner
  • 7 Posts
  • 2 Topics
  • 0 Solutions
Registered:
I also had this problem and this solution solved it, temporarily. Since restoring the wifi calling, I have not since turned the phone on and off or restarted it although I had turned mobile data and wi-fi on and off a few times. This afternoon I noticed wifi calling and the option to turn it on have all disappeared again. Is there a more permanent fix as this is aggravating?
Message 5 of 7
3,550 Views

MI5
Level 94: Supreme
  • 120831 Posts
  • 605 Topics
  • 18249 Solutions
Registered:

@BSB1 

Waiting for Samsung to fix the bug unfortunately.

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 6 of 7
3,548 Views

Chill
Level 1: Joiner
  • 1 Posts
  • 0 Topics
  • 0 Solutions
Registered:
Exactly the same problem on an S20+ on O2. No option in phone settings to switch on WiFi calling. Solution as already stated. switch off phone. Remove SIM. Switch on phone, wait until its completely restarted. Insert SIM and the WiFi calling option is there. I am guessing its a S20 firmware problem.
Message 7 of 7
3,066 Views