cancel
Showing results for 
Search instead for 
Did you mean: 

Calls over wifi unlocked S7

Wynnem74
Level 1: Joiner
  • 4 Posts
  • 1 Topics
  • 0 Solutions
Registered:
Hi all I am hoping someone could please help. I purchased an unlocked S7 not realising that calls over wifi would not work as it was not direct from O2. Is there a work around for this or have I made a school boy error?
Message 1 of 9
2,601 Views
8 REPLIES 8

MI5
Level 94: Supreme
  • 119490 Posts
  • 605 Topics
  • 17412 Solutions
Registered:
You can flash O2 firmware, although we can't tell you how to do that, but if you search on XDA you will find out.
I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 2 of 9
2,599 Views

anticpated
Level 28: Ingenious
  • 3186 Posts
  • 135 Topics
  • 42 Solutions
Registered:

Unfortunately that is a network dependant feature and I was miffed to find out unless whatever network you use has to provision the use of data calling. I'm not sure if iPhone has the same issue although I've seen it working on Three and Vodafone without any issues.

 

It seems to be another way for networks to lock you into ownership or at least to ensure they use their network. Anyway hope you get it fixed one way or another.

Leave your candy-colored cans in the toy chest and try a pair of proper headphones.
Message 3 of 9
2,569 Views

Wynnem74
Level 1: Joiner
  • 4 Posts
  • 1 Topics
  • 0 Solutions
Registered:
Thanks for your reply. I did try this using Odin and seemed successful but the option for wifi calls is still not there. I am worried i am missing something?
Message 4 of 9
2,532 Views

Wynnem74
Level 1: Joiner
  • 4 Posts
  • 1 Topics
  • 0 Solutions
Registered:
Thanks for your reply. I did try this using Odin and seemed successful but the option for wifi calls is still not there. I am worried i am missing something? Any other thoughts or ideas greatly appreciated
Message 5 of 9
2,525 Views

MI5
Level 94: Supreme
  • 119490 Posts
  • 605 Topics
  • 17412 Solutions
Registered:
So now you need to go I to your MyO2 and turn on the option for WiFi and 4g calling, then give it up to 24 hours and reboot your phone.
I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 6 of 9
2,519 Views

Wynnem74
Level 1: Joiner
  • 4 Posts
  • 1 Topics
  • 0 Solutions
Registered:
M15 I have done this also. I am really pulling my hair out with this. Would it be an issue with phone itself? Or does it need good connection to mast to update phone as i have not been out since doing and have a poor reception in house?
Message 7 of 9
2,516 Views

MI5
Level 94: Supreme
  • 119490 Posts
  • 605 Topics
  • 17412 Solutions
Registered:

Yes you will need a network connection for your sim to update but check first you are looking in the right place for your settings.....

  1. To enable Wifi Calling, go to Settings > Connections > Wi-Fi calling. Make sure Wi-Fi calling is set to On. To switch off Wifi Calling, set the toggle to Off

    If you can’t find the settings here, try going to Phone > tap the 3 dots in the top right corner > Settings > scroll down to find Wifi Calling and toggle On.

  2. To switch on 4G Calling, go to Settings > Connections > Mobile networks > 4G calling. Make sure Wi-Fi calling is set to On. To switch off 4G Calling, set the toggle to Off.
I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 8 of 9
2,514 Views

woodmj
Level 2: Apprentice
  • 46 Posts
  • 12 Topics
  • 0 Solutions
Registered:

If the S7 behaves the same as my S9 on O2 you will only get WiFi calling if your phone can't latch on to any kind of O2 cellular signal at all. This can be tested by putting the phone into Flight Mode and then just enabling WiFi. To get back onto the O2 cellular network you would need to switch off Flight Mode.

 

Hope that helps.

Message 9 of 9
2,431 Views