cancel
Showing results for 
Search instead for 
Did you mean: 

Internet settings for ancient Sony Ericsson J105

KeefyW
Level 1: Joiner
  • 22 Posts
  • 3 Topics
  • 0 Solutions
Registered:

Hi Folks. Could someone help me please.

I have recently resurrected my old Sony Ericsson. It does everything I need but something appears to have killed my internet access. Does anyone know the settings ?

The ones I have got in and am sure are right are in blue. The ones I'm not sure about (most of them) in red.

APN - payandgo.o2.co.uk

Username - payandgo

Password - password

Login request - off

IP address - (empty field)

DNS address (empty field)

Authentication - none

Data compression - off

Header compr. - off

Proxy settings - On, Multiple

 

 o2 site not helpful for non smart phones.

 

Please help. It used to work and I have no idea what I did to wreck it. Thanks folks.

Message 1 of 17
358 Views
16 REPLIES 16

MI5
Level 94: Supreme
  • 119579 Posts
  • 605 Topics
  • 17480 Solutions
Registered:

You only need the ones in blue @KeefyW 

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 2 of 17
302 Views

KeefyW
Level 1: Joiner
  • 22 Posts
  • 3 Topics
  • 0 Solutions
Registered:

Thanks @MI5 . So I've just emptied all the other fields, leaving the top three as they were. I am still getting the error 'Communication failure. Secure connection failed'.

The only reference to secure is in the proxy settings. If I  turn that on it wants username, password, proxy address and port (prefilled to 8080). Beginning to really get on my nerves rage

Regards - Keith

 

PS. It was you who pointed me in the direction of new batteries for it. It's such a great little phone and I love it. It would still be in the 'dead phone drawer' but for you ! Thanks...

Message 3 of 17
292 Views

MI5
Level 94: Supreme
  • 119579 Posts
  • 605 Topics
  • 17480 Solutions
Registered:

Hi @KeefyW 

Glad you got it working.

Can you try Menu > Settings > User help > Settings download ?

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 4 of 17
284 Views

KeefyW
Level 1: Joiner
  • 22 Posts
  • 3 Topics
  • 0 Solutions
Registered:

No. Sadly this option doesn't appear as an option in User help menu. If I choose Internet from the User guide it points me to the same (non-existent) link. I just get User guide, Basic setup (language options only) and Tips and tricks as options in the User help menu.

 

I'm going to have a look in the settings of my Nokia 216 (horrible little phone). Hope they are still there and accessible. If I get any clues I'll post back.

 

Thanks for trying @MI5 . Best wishes - Keith

Message 5 of 17
281 Views

MI5
Level 94: Supreme
  • 119579 Posts
  • 605 Topics
  • 17480 Solutions
Registered:

@KeefyW 

You could try

Login request - On

and then try different authentication options.

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 6 of 17
278 Views

KeefyW
Level 1: Joiner
  • 22 Posts
  • 3 Topics
  • 0 Solutions
Registered:

Hey @MI5 ! Thanks for bearing with me on this. I have a feeling we'll get there eventually!!! Tried the Login request option but it just puts the username on the screen (OK) then the password (OK) for confirmation before trying to connect. Tried and continue to try various other combinations but...

If I try connecting to http - all ok. Works fine but https > comms error every time. BBC site is interesting. Seems to connect but keeps telling me about certificate error or the date/time on my phone is wrong (which it isn't). Does however connect eventually. Bizarre... I will keep you posted if when I get to the bottom of it.

 

I checked the settings on my wife's L3 (PAYG) and the username is simply o2 and the password is just a single *, not 8 like mine. If I knew what the * was I'd try that user/pass pair. Any ideas what the single character password for that is? The APN is the same as mine. Cheers

 

PS Noticed you use SFR. C'est un bon reseau. Ma femme est Francaise et nous avons souvent visite avant le plague mondial!!!

Message 7 of 17
264 Views

MI5
Level 94: Supreme
  • 119579 Posts
  • 605 Topics
  • 17480 Solutions
Registered:

@KeefyW 

Ce serait bien d'y retourner bientôt. 

Sorry, no idea what a single letter password could be. It's always just been "password"

You could try without anything in that field?

I'll sleep on it and come back in the morning if I think of anything else....

PS. Is your date and time set to auto?

 

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 8 of 17
255 Views

KeefyW
Level 1: Joiner
  • 22 Posts
  • 3 Topics
  • 0 Solutions
Registered:

J'espere. Nous n'avons pas de bon vin ou du cafe dans les armoires. Et le foie gras ! C'est impossible a l'acheter en Angleterre.
Time settings - auto. Usually updates itself after a battery change but I reset it manually just in case that had something to do with it. Just tried Françoise's SIM. No change. Close to giving up... Close but let's see what the morning brings. Bon nuit.

Message 9 of 17
249 Views

MI5
Level 94: Supreme
  • 119579 Posts
  • 605 Topics
  • 17480 Solutions
Registered:

Le fromage me manque slight_smile

Should be set to auto so leave it there......

Check if there is a setting for certificates or certificate management, if so, set it to automatic.

After that, I'd delete all the apn's and just set one new one with the basic settings for data:

  • Name: o2 Internet
  • APN: payandgo.o2.co.uk
  • Username: payandgo
  • Password: password
  • Authentication type: PAP (If offered)
  • APN type: If you're given a choice of options, choose "internet"
  1. Tap Menu > Save
  2. Choose the name that we have just created
  3. Make sure it's highlighted with the dot or tick, however it's displayed.
  4. Reboot phone and check.
I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 10 of 17
225 Views