Welcome to the O2 Community

Has your question already been answered? See the community FAQ's
Reply
Anonymous
Posts: 0
Accepted Solution

Priority App

I want to download 02 priority onto my Android phone. I'm being told that my phone is incompatible with the current version. Is there an older version? Don't want to miss out!

Posts: 88,630
Topics: 536
Solutions: 11,502
Registered: ‎04-04-2012

Re: Priority App

[ Edited ]

The app won't work on older phones now due to security issues.
You can still login online though with your browser https://priority.o2.co.uk/

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone7 (EE)
Anonymous
Posts: 0

Re: Priority App

Thanks for the reply, yes we can still login to 02 and priority etc but cant use the phone itself.

Posts: 70,516
Topics: 548
Solutions: 3,428
Registered: ‎04-01-2009

Re: Priority App

You could Google for the apk to find an older version but downloading to the phone would be at your own risk I'm afraid.

What phone and os are you using out of interest. 

Posts: 88,630
Topics: 536
Solutions: 11,502
Registered: ‎04-04-2012

Re: Priority App

Android 4.3 and up only. Older apk’s won’t connect even if installed I’m afraid.
The only options are using the phones web browser or updating phone / software.
I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone7 (EE)