O2 Community

Get help, share tips and chat

Level 1: Joiner
Posts: 10
Registered: ‎26-08-2012
Accepted Solution

Samsung Galaxy S3 - Not Registered on Network

Got the new phone yesterday and registered the SIM online.


All seems to be fine, the phone is showing full signal, but every time I attempt to make a call, I get an error "Not Registered to Network". I have tried switching it off and on, leaving it off for a few hours, trying in 2G only mode, trying to manually select network. When I select a network, even O2 - UK, it says that it can't register to the network. When I select automatic, it will sometimes fail, but after a few taps it will say it's registered successfully.


So, basically, I have full signal, but am connected to no network. Any ideas?

Level 4: Observant
Posts: 31
Registered: ‎12-10-2012

Re: Samsung Galaxy S3 - Not Registered on Network

It does sound like your SIM is half-way through the registration process. I know having registered the SIM for over 24 hours now it should have gone through, but in all truthfulness the issues that O2 were experiencing yesterday could very well have caused a backlog in your registration being pushed through.


Can you send an SMS? Also, what version of Android are you running at current on the S3?


If the issue persists, I would suggest ringing O2 Customer Care, as they are the only ones with the resources to tell whether your handset is "live" on the network or not.

Level 1: Joiner
Posts: 10
Registered: ‎26-08-2012

Re: Samsung Galaxy S3 - Not Registered on Network

Think it was just the delay that was causing the issues, I'm getting some services now. Thanks!
Level 1: Joiner
Posts: 3
Registered: ‎02-11-2013

Re: Samsung Galaxy S3 - Not Registered on Network

I had the same problem on both mine and my wifes phone. Galaxy s 3 mini. contacted o2 Guru, we tried all of the following.Battery and Sim card removal,stand on one leg the lot. None of them worked.The phone would not see the network..... But I have found the fix that did work on the Galaxy mini 3 anyway.  

AS followes- With the phone switched on remove the battery. Then remove the sim card and wipe it with a soft clean cloth.Now replace the sim card and battery./ Thats it switch back on. Job done.Note: ( Remember to remove the battery with the phone switched on. )

Posts: 27,020
Topics: 247
Solutions: 1,614
Registered: ‎29-07-2008

Re: Samsung Galaxy S3 - Not Registered on Network

Good tip, but the thread is over a year old. Smiley Happy

To support Disasters Emergency Committee: http://www.dec.org.uk/appeals text Nepal to 70000 to send £5

Sky Unlimited Broadband - Windows 10 - Nexus 4 Android 5.1.1