cancel
Showing results for 
Search instead for 
Did you mean: 

Help with online issues

EMjayf
Level 1: Joiner
  • 4 Posts
  • 1 Topics
  • 0 Solutions
Registered:

Help! I can't get my Xperia-SP phone to connect to the internet any more.

It was fine Saturday but over the weekend it has stopped connecting even though I have a strong internet connection at work AND at home. I've asked in forums and friends but I'm getting nowhere!

 

I don't know if it helps but it DOES seem to connect online - but only through a browser.

 

The Apps won't connect.

So I can look at Facebook through Chrome (on the basic browser) - but not through the App.
I can check my Yahoo emails through Chrome (on the basic browser) - but not through the App.

So the issues seem to be there?

Also I've been playing the Sims - I can play offline but if I click on the Party button (which connects you to other users) it doesn't work.

 

Does THIS narrow doen what the issue might be?

I've tried various other things but it doens't make sense!  I did download a BT wifi app (as we're on through BT at home) - but to be honest I used to get online without this App before!

I've been pulling my hair out about this for DAYS and I keep trying different settings - so much so that I'm just getting more and more confused!

Please can anyone help?!  Thanks very much
MJ

Message 1 of 7
2,609 Views
6 REPLIES 6

MI5
Level 94: Supreme
  • 119330 Posts
  • 605 Topics
  • 17279 Solutions
Registered:
Are you trying to connect over wifi or mobile data?
Have you tried both ways to see if problem is with one or the other?
I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 2 of 7
2,605 Views

Cleoriff
Level 94: Supreme
  • 103655 Posts
  • 780 Topics
  • 4833 Solutions
Registered:
Message 3 of 7
2,586 Views

EMjayf
Level 1: Joiner
  • 4 Posts
  • 1 Topics
  • 0 Solutions
Registered:

Yes I've tried connecting through my BT Wifi account at home and it used to work fine (although it's weird that it often comes up with authentication problems!  Even though I put the password and stuff in fine) - also my work account worked fine - all before the weekend.

I THINK the internet works through a browser (this would be mobile data I think) - I can open Facebook in a browser but the Facebook app itself can't connect (nor Instagram, nor online to get to The Sims).  It seems that it's apps and online that are an issue.

My Wi-fi at home used to work fine - and my one at work but now it doesn't.  I've had so many suggestions and I keep changing settings but I'm getting worried that I'm just messing things up more!

There must be something that got changed at the weekend that I hadn't meant to change!

Message 4 of 7
2,541 Views

EMjayf
  • 4 Posts
  • 1 Topics
  • 0 Solutions
Registered:
Not sure - I've ran out of battery! I can check that link later - I know that I'm Pay and Go with O2, but I've been connecting to the internet at home with wi-fi and BT if this helps?
Message 5 of 7
2,534 Views

viridis
Level 56: Guvnor
  • 13432 Posts
  • 95 Topics
  • 301 Solutions
Registered:
I'd be tempted to back it up and factory reset



Message 6 of 7
2,529 Views

MI5
Level 94: Supreme
  • 119330 Posts
  • 605 Topics
  • 17279 Solutions
Registered:
I think so too - If you've been messing with settings a factory reset is the only way to go about fixing it.
I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 7 of 7
2,476 Views