cancel
Showing results for 
Search instead for 
Did you mean: 

SMS won't send from Alcatel 1X

ADB57
Level 2: Apprentice
  • 8 Posts
  • 1 Topics
  • 1 Solutions
Registered:

I have been unable to send SMS from my Alcatel 1X since switching it off, and then on again. I am able to receive texts.

Within the Messaging app, I select Settings, then Advanced. At the bottom of the screen it says Phone number 07802-092035. This is the SMS message centre number for O2 PAYG.

HOWEVER

When I dial *#*#4636#*#*, and go to Phone Info, there is nothing listed behind Phone number. I would assume that would display the actual number for the phone, as the SMSC number is listed further down the list of information.

Another oddity is when I go into the phone's Settings and select Network & connection, Mobile Network,  then Access Point Names, it displays O2 Pay Monthly, which is NOT the service I use; I'm on Pay as you go.

Pay Monthly has a different SMS service centre number, but using that still does not enable me to send SMS.

 

Message 1 of 16
440 Views
1 ACCEPTED SOLUTION

Accepted Solutions

ADB57
Level 2: Apprentice
  • 8 Posts
  • 1 Topics
  • 1 Solutions
Registered:

I think it'll have to be a hard reset. Many thanks for your efforts.

View solution in original post

Message 16 of 16
338 Views
15 REPLIES 15

pgn
Level 62: Glorious
  • 23409 Posts
  • 172 Topics
  • 589 Solutions
Registered:

Hi @ADB57 - you need to take a look at Guide: Text Message Tips (not sent or received) and make sure your phone is set to the correct type, viz. PAYG and not Pay Monthly.

Good luck!

O2CommunityAwardNotCS




O2 Social Media
SM Icons(Twitter | Instagram | Facebook)















Message 2 of 16
315 Views

ADB57
Level 2: Apprentice
  • 8 Posts
  • 1 Topics
  • 1 Solutions
Registered:

As stated in the question, the message centre number appears to be  correct. However, the phone seems to be set for Pay Monthly, which I cannot seem to be able to change.

Message 3 of 16
307 Views

pgn
Level 62: Glorious
  • 23409 Posts
  • 172 Topics
  • 589 Solutions
Registered:

There's an SMS number you can text, or a link on O2 website to get it sent to your phone, to get your settings reset based on PAYG or Pay Monthly - and the number you show above lacks the +44 (and has a dash?) as shown in the guide, @ADB57.

Can't find the link, used to be on the SIM card envelope, maybe in MyO2 somewhere now.

O2CommunityAwardNotCS




O2 Social Media
SM Icons(Twitter | Instagram | Facebook)















Message 4 of 16
305 Views

pgn
Level 62: Glorious
  • 23409 Posts
  • 172 Topics
  • 589 Solutions
Registered:

Slightly old info but I cannot find anything specific on O2 site for the 1X

 

https://www.o2.co.uk/help/phones-sims-and-devices?page=device/alcatel/1/topic/texts-and-picture-mess...

 

 

O2CommunityAwardNotCS




O2 Social Media
SM Icons(Twitter | Instagram | Facebook)















Message 5 of 16
297 Views

ADB57
Level 2: Apprentice
  • 8 Posts
  • 1 Topics
  • 1 Solutions
Registered:

The number on the phone is without a dash.

On MyO2, my device is NOT listed as Alcatel 1X, but as Nokia 1600 (which I used until two years ago). I don't see any way to change this myself, do I need to contact O2 to have this done?

Message 6 of 16
285 Views

pgn
Level 62: Glorious
  • 23409 Posts
  • 172 Topics
  • 589 Solutions
Registered:

There is no way to change it yourself, @ADB57 - it usually changes of its own accord within a few days of moving to a new handset model - although I have had one take several months (Android phones).

You can edit the name tag that shows in MyO2 though to say anything you want by clicking the pencil icon next to the device name in your MyO2 online.

 

 

O2CommunityAwardNotCS




O2 Social Media
SM Icons(Twitter | Instagram | Facebook)















Message 7 of 16
284 Views

ADB57
Level 2: Apprentice
  • 8 Posts
  • 1 Topics
  • 1 Solutions
Registered:

 Which leaves me with the discrepancy in message centre numbers. In Messenger, this is the number for O2 PAYG (07802092035), in the phone itself (through *#*#4636#*#*), it is the number for contracts, 07802000332. Changing this makes no difference - I still cannot send a text message 🙂

Message 8 of 16
272 Views

jonsie
Level 94: Supreme
  • 86807 Posts
  • 594 Topics
  • 5060 Solutions
Registered:

The message centre number must be in the +44 format

IE  +447802092035

2020-Awards-jonsie5695219-2




O2 Social Media

SM Icons(Twitter |
Instagram | Facebook)




































5695219-2
Message 9 of 16
272 Views

ADB57
Level 2: Apprentice
  • 8 Posts
  • 1 Topics
  • 1 Solutions
Registered:

The phone immediately converts it to 07802092035 🙂

Message 10 of 16
265 Views