cancel
Showing results for 
Search instead for 
Did you mean: 

no signal xperia 10 11

Willtt
Level 1: Joiner
  • 4 Posts
  • 3 Topics
  • 0 Solutions
Registered:

I have been using a new Sony Xperia 10ii from O2 for a few days. The signal in the house is almost non existent, and patchy outdoors even near a transmitter. My previous phone (a motorola ) had a good signal in and out of the house, as does an iphone 5s. I have contacted O2 but they have not come up with a solution. As I am still within the return period I am thinking of sending it back as faulty, which would be a pity because it has some decent features, luckily including wifi calling which is the only way to call from the house.

I have tried resetting and restarting, turning off wifi etc, but nothing seems to make any difference.

Any suggestions?

Message 1 of 2
243 Views
1 ACCEPTED SOLUTION

Accepted Solutions

Cleoriff
Level 94: Supreme
  • 112578 Posts
  • 801 Topics
  • 6713 Solutions
Registered:

@Willtt 

Have you checked your network status? https://status.o2.co.uk/ 

Community help here Guide: How can I sort out my network issues? 

Take thee sim out, clean and reinsert. Reboot the phone

Edited to add, if nothing improves, you have 14 days to change your mind about the phone.

https://www.o2.co.uk/help/phones-sims-and-devices/our-change-of-mind-policy 

Veritas Numquam Perit

Girl in a jacket

View solution in original post

Message 2 of 2
234 Views
1 REPLY 1

Cleoriff
Level 94: Supreme
  • 112578 Posts
  • 801 Topics
  • 6713 Solutions
Registered:

@Willtt 

Have you checked your network status? https://status.o2.co.uk/ 

Community help here Guide: How can I sort out my network issues? 

Take thee sim out, clean and reinsert. Reboot the phone

Edited to add, if nothing improves, you have 14 days to change your mind about the phone.

https://www.o2.co.uk/help/phones-sims-and-devices/our-change-of-mind-policy 

Veritas Numquam Perit

Girl in a jacket
Message 2 of 2
235 Views