cancel
Showing results for 
Search instead for 
Did you mean: 

auto-balance confirmation?

Anonymous
Not applicable
some years back I emailed someone at o2 and got them to remove that stupid feature of every time I sent a text or MMS, I got a PAY as ya go balance screen sent to my phone.

the problem, is that this usually comes several seconds after sending, so the phone is in sleep mode by then, unfortunately you wont be informed of any new messages till you OK that balance screen, then suddenly already recieved and unread messages will show up.

its been a few years since i got shut of this, but now, for some reason on MMS messages I send - ive started getting this stupid feature back.

cant this be a selectable feature for pay as you go customers? and off my default? how do I get it taken off again?
Message 1 of 7
1,143 Views
6 REPLIES 6

Anonymous
Not applicable
you need to contact customer service and ask them to turn balance notifications off
Message 2 of 7
1,143 Views

Anonymous
Not applicable
you need to contact customer service and ask them to turn balance notifications off


Re-read the first post, they've already been turned off.

I can confirm that even if you have had the balance notifications turned off, the balance appears after sending an MMS.
Message 3 of 7
1,143 Views

Anonymous
Not applicable
sorry if I wasn't completely clear, when I send a mms (or do anything chargeable) I don't get balance notification

maybe then have been partially turned back on in error perhaps or maybe something has reset
Message 4 of 7
1,143 Views

Anonymous
Not applicable
thanks Guys -

yeah this had been turned off for both sms and mms messages must be a couple of years ago now, Ive done nothing to my phone, but about a month ago mms started giving me these infuriating balance confirmations.

Now Ive emailed o2, and someone got back to confirm that these are still turned off on the account side, but that this is a SIM card setting and i would still get them?

I dont understand why tbh - since the first time I didnt have to touch my phone settings , they just disabled this and it worked for years till a month ago?

ive tested again and its still happening.

sigh.
Message 5 of 7
1,143 Views

Anonymous
Not applicable
an update on this - this is a o2 side issue entirely, after they originally told me that the problem was with settings on my phone - after pushing this back to them, someone else at o2 who seems to know the issue told me they enabled the settings again, then disabled them again - this worked for me.
Message 6 of 7
1,143 Views

Anonymous
Not applicable
simulation credit auto
I like where this thread is going. But I do not feel creative enough to contribute at this time. :womanindifferent:
Message 7 of 7
1,143 Views