cancel
Showing results for 
Search instead for 
Did you mean: 

Texts

Marcus1
Level 1: Joiner
  • 4 Posts
  • 1 Topics
  • 0 Solutions
Registered:
When I sent a text message to another iPhone they do not receive messages from my iPhone and I have to turn on iMessage
Message 1 of 9
295 Views
8 REPLIES 8

O2LaurenC
O2 Support
O2 Support
  • 17 Posts
  • 0 Topics
  • 0 Solutions
Registered:

Hello Marcus, 

 

On the secondary phone, are you able to confirm the email address and/or number connected to their iMessage? This can be checked with Settings > Messages > (Ensure iMessage is turned on) Send & Receive. There will be a mobile number and email address. For the text to be received there will need to be a blue tick to the left of the number or email address being used.

 

Hope this helps, any issues don't hesitate to reply!

Message 2 of 9
286 Views

MI5
Level 94: Supreme
  • 128279 Posts
  • 614 Topics
  • 22547 Solutions
Registered:

@Marcus1 

Do you have send as sms enabled in the message settings?

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 3 of 9
279 Views

Marcus1
Level 1: Joiner
  • 4 Posts
  • 1 Topics
  • 0 Solutions
Registered:
When I don’t have iMessage on they can’t get my messages
Message 4 of 9
277 Views

Marcus1
Level 1: Joiner
  • 4 Posts
  • 1 Topics
  • 0 Solutions
Registered:
SMS in turn on and if I send it from my phone the other phone can’t receive the messages
Message 5 of 9
276 Views

MI5
Level 94: Supreme
  • 128279 Posts
  • 614 Topics
  • 22547 Solutions
Registered:

@Marcus1 

Interested as to why you would turn iMessage off?

iPhones are designed around it being on always....

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 6 of 9
269 Views

Marcus1
Level 1: Joiner
  • 4 Posts
  • 1 Topics
  • 0 Solutions
Registered:
It has been off since I got the hone and it’s only just started happening since the last update
Message 7 of 9
249 Views

MI5
Level 94: Supreme
  • 128279 Posts
  • 614 Topics
  • 22547 Solutions
Registered:

@Marcus1 

Must be something in iOS then, but there's no reason to turn off iMessage that I can see.

Everything should work find as far as messaging goes, to all pones, with it turned on.

You can also use WhatsApp etc if the recipient also uses other messaging apps.

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 8 of 9
238 Views

O2LaurenC
  • 17 Posts
  • 0 Topics
  • 0 Solutions
Registered:

@Marcus1 I would recommend turning your phone off and on again, as well as resigning into your Apple ID. If it continues it may be a bug with the IOS update that has recently come out in the last few days.

 

If a message doesn't go through because it's an iMessage (the message bubble will be blue) and iMessage is turned off, send the message and hold down on it. You will then be given the option to send as an SMS (to which the message turns green).

 

Message 9 of 9
232 Views