cancel
Showing results for 
Search instead for 
Did you mean: 

MMS not sending

Gemma459
Level 1: Joiner
  • 1 Posts
  • 1 Topics
  • 0 Solutions
Registered:
I have an iPhone 11, since getting this phone I am having trouble sending MMS to non iPhone users or those who don’t have iMessage activated. I’ve tried resetting settings, tried different network passwords I was given by o2 and nothing has worked. Any ideas ?
Message 1 of 3
138 Views
1 ACCEPTED SOLUTION

Accepted Solutions

MI5
Level 94: Supreme
  • 127458 Posts
  • 614 Topics
  • 22138 Solutions
Registered:

@Gemma459 

Is mms turned on in message settings?

You may also have set a spend cap which will prevent sending Guide: Spend caps on O2 

You'll need to ask O2 to change it if you have.

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)

View solution in original post

Message 2 of 3
135 Views
2 REPLIES 2

MI5
Level 94: Supreme
  • 127458 Posts
  • 614 Topics
  • 22138 Solutions
Registered:

@Gemma459 

Is mms turned on in message settings?

You may also have set a spend cap which will prevent sending Guide: Spend caps on O2 

You'll need to ask O2 to change it if you have.

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 2 of 3
136 Views

Bambino
Level 78: King of Kings
  • 19834 Posts
  • 961 Topics
  • 2828 Solutions
Registered:

@Gemma459 Stop wasting your data allowance and send your MMS via WhatsApp or Facebook Messenger, which cost zero to send or receive.

I DO NOT WORK FOR O2



Funniest-Thread-2
Message 3 of 3
132 Views