cancel
Showing results for 
Search instead for 
Did you mean: 

Does anyone in o2 Customer Services have a clue!?

Anonymous
Not applicable
For weeks now I have been phoning them and emailing them to try to sort out what should be a simple problem.

Basically, I can't 'receive' MMS - even though I can happily send them, and browse the web etc...

I've tried getting a new sim card. I've tried the sim in various MMS capable phones. But I still get a txt message saying 'log onto o2.co.uk/m/' to view.

It's so frustrating, but I keep getting no help at all.

Useless.

With this in mind, if I'm not getting the service i'm paying for, I'm considering the legality of cancelling my contract with them.
Message 1 of 4
555 Views
3 REPLIES 3

Anonymous
Not applicable
I've come across this issue myself with MMS.

I'm assuming that you keep being sent settings and told to restart the phone?

If that doesn't work then, like me, you may need MMS reprovisioned to your account i.e. MMS turned off then back on again. This is done very easily and will usually take about 15 mins to turn off and then another 15 mins to turn back on again (if the advisor is keeping a close eye on it, they need to turn it back on again manually).

Also, if you have an iphone there are a couple of other things to check. If you're on an iphone tariff have you made sure that they've activated MMS on your account? They can do this manually for you. If you have an iphone but aren't on an iphone tariff have you gone to settings>general>network>cellular data network and made sure the MMS APN is set to wap.o2.co.uk
Message 2 of 4
555 Views

Anonymous
Not applicable
Simple solution.

Speak with Customer Services its your APN's that arent set up correctly.

You will be set to
idata.o2.co.uk and need to be mms.o2.co.uk or wap.o2.co.uk.

give cust services a ring and they will talk you through it.
Message 3 of 4
555 Views

Anonymous
Not applicable
Simple solution.
Speak with Customer Services its your APN's that arent set up correctly.
You will be set to
idata.o2.co.uk and need to be mms.o2.co.uk or wap.o2.co.uk.
give cust services a ring and they will talk you through it.


I'm not using an iPhone

I've tried the settings with an N97, a U600, a G600

all the same problem.
Message 4 of 4
555 Views