cancel
Showing results for 
Search instead for 
Did you mean: 

4g doesn't seem to be working - s20 ultra (5g)

Jak
Level 1: Joiner
  • 2 Posts
  • 1 Topics
  • 0 Solutions
Registered:
I've just bought an s20 ultra 5g as I broke my s20fe. I put the sim in the ultra and 4g doesn't seem to be working. I put the sim in another phone to check if it was poor coverage/signal but 4g showed up straight away. I've checked the network settings, it's currently on "GLOBAL" do I need to change it? There isn't a 4g option. It's not a 5g sim/ tariff so wouldn't get 5g.
Is there something I need to do manually to get 4g going?
Message 1 of 4
227 Views
3 REPLIES 3

Cleoriff
Level 94: Supreme
  • 110777 Posts
  • 799 Topics
  • 6381 Solutions
Registered:

@Jak 

The 4G issue shows a fix in this article..

https://thedroidguy.com/galaxy-s20-no-4g-lte-signal-easy-fixes-1124573 

 

*The Game Is On*

Girl in a jacket
Message 2 of 4
225 Views

Martin-O2
  • 7982 Posts
  • 748 Topics
  • 93 Solutions
Registered:

Hey @Jak how are you getting on with this issue? 

COVID-19 support - Help and support from O2 during the lockdown
Access for You: Registration - Find out how to register for our Access for You service.
Just joined the community or thinking of registering? Check out this handy starter guide!
Have a query about your account? login to My O2 for help


If you'd like to take part, why not register? slight_smile
signature

Message 3 of 4
169 Views

Jak
Level 1: Joiner
  • 2 Posts
  • 1 Topics
  • 0 Solutions
Registered:
Hey Martin, I'm going to return the phone. Had no joy connecting to 4g, every so often I get LTE but it's literally for seconds then drops back down to h/h+. After checking the processor and csc code, it turns out its the American build.
It's a shame as the snapdragon chip is miles better than exynos, the phone is mega responsive and the battery is unreal (took it off charge at 8am and it still has 38% now - 9.30pm - that's with relatively heavy use)
Message 4 of 4
153 Views