cancel
Showing results for 
Search instead for 
Did you mean: 

4G activation delayed

Anonymous
Not applicable

Signed up for 4G tarrif this morning and as of now am awating for it to be activated . My order status is still showing as "In Progress".

 

Call O2 after 30 minutes some one picks up and tell me that it will be upto 24 hours before 4G is activated. This must be a joke right ???

Message 1 of 26
2,940 Views
1 ACCEPTED SOLUTION

Accepted Solutions

Anonymous
Not applicable
Turning your phone off and on helps reset your services.

Up to 24 hours to reset services is the norm for 02 ,but it can also be much quicker depending how busy the network is.

This is launch day so it's not unexpected to hit some snags.

View solution in original post

Message 2 of 26
2,815 Views
25 REPLIES 25

Anonymous
Not applicable
Turning your phone off and on helps reset your services.

Up to 24 hours to reset services is the norm for 02 ,but it can also be much quicker depending how busy the network is.

This is launch day so it's not unexpected to hit some snags.

Message 2 of 26
2,816 Views

Anonymous
Not applicable

Did exactly the same this morning, now says Active on my account, and received a text saying I was ready to go.

 

Am in a strong 4g area, but still got H+ showing on my handset.

 

Hmph...

 

Alan

 

Message 3 of 26
2,768 Views

Anonymous
Not applicable

Hi,

 

 

What phone do you own ?

Message 4 of 26
2,766 Views

jonsie
Level 94: Supreme
  • 86795 Posts
  • 594 Topics
  • 5058 Solutions
Registered:

Presuming you have changed to a 4G sim, have you tried rebooting the phone? Is 4G showing as an option in network settings?

2020-Awards-jonsie5695219-2




O2 Social Media

SM Icons(Twitter |
Instagram | Facebook)




































5695219-2
Message 5 of 26
2,765 Views

Anonymous
Not applicable

Hi, I got a new 4g enabled sim last week, and it was activated.  

 

My phone is a Samsung Galaxy S4, direct from Samsung, not an o2 provided one, running Android 4.2.2

 

I have rebooted the phone a number of times, but it still shows H+ on the display.

 

Alan

 

Message 6 of 26
2,757 Views

Anonymous
Not applicable

Someone mentioned earlier that the s4 is awaiting a patch to allow 4G to work but its not been confirmed !

Message 7 of 26
2,752 Views

Anonymous
Not applicable

I can't see anything relating to 4g in network settings...  Although I can't see anything relating to 3g either :-s

 

A

Message 8 of 26
2,751 Views

jonsie
Level 94: Supreme
  • 86795 Posts
  • 594 Topics
  • 5058 Solutions
Registered:

Have you selected the correct mode?

 

  1. Tap your Menu Key
  2. Go to Settings
  3. Tap More Networks
  4. Go to Network Mode
  5. Select the Network that you want. For 4G/LTE, choose the LTE/CDMA option. For 3G, choose CDMA.
  6. Tap OK and the device will apply the new settings and restart......apparently!
2020-Awards-jonsie5695219-2




O2 Social Media

SM Icons(Twitter |
Instagram | Facebook)




































5695219-2
Message 9 of 26
2,746 Views

Anonymous
Not applicable

My phone doesn't mention LTE/CDMA.

 

I've got:  

 

WCDMA / GSM (autoconnect)

WCDMA only

GSM only

 

It's currently set to WCDMA / GSM (auto connect)

 

Thanks for your help by the way.

 

This isn't an o2 S4, bought sim free from Expansys, don't know if that makes a difference.

 

Alan

 

Message 10 of 26
2,741 Views