cancel
Showing results for 
Search instead for 
Did you mean: 

Where do I enter the code when trying to log into my account?

RustyKnight
Level 1: Joiner
  • 4 Posts
  • 1 Topics
  • 0 Solutions
Registered:

When I try logging into my account on the O2 website I get a security message, and a code is sent to my phone.

 

The problem is there's nowhere on the website to enter the code!

 

I thought it was impossible to access my account because of this but when I click My O2 I'm logged in any way - so what is the point of a system that sends a useless code?

Message 1 of 16
246 Views
1 ACCEPTED SOLUTION

Accepted Solutions

pgn
Level 61: Brainiac
  • 23295 Posts
  • 172 Topics
  • 578 Solutions
Registered:

One further thing that *might* work - have you tried accessing the forum from an Incognito tab in your browser?  And ditto from a new Incognito window for O2.co.uk main site?

The problem seems to stem from both Forum and main O2 website using the same authentication system.

Forum: https://community.o2.co.uk/

Site: https://o2.co.uk

 

Worth a shot, @RustyKnight.

O2CommunityAwardNotCS




O2 Social Media
SM Icons(Twitter | Instagram | Facebook)















View solution in original post

Message 7 of 16
143 Views
15 REPLIES 15

pgn
Level 61: Brainiac
  • 23295 Posts
  • 172 Topics
  • 578 Solutions
Registered:

This is a recent addition, @RustyKnight - I had no problem seeing the box on my Android phone with Chrome browser, but somebody on laptop with FireFox gets as you describe. In my case, the system forced me to choose a new password after entering the code into the box, so be prepared.

All I can suggest is to make sure your browser has been restarted recently and try again - or switch to Chrome on a PC or mobile to get past that step. Once done, you should not be challenged again. Good luck.

1651844443860.jpg

O2CommunityAwardNotCS




O2 Social Media
SM Icons(Twitter | Instagram | Facebook)















Message 2 of 16
170 Views

Cleoriff
Level 94: Supreme
  • 110661 Posts
  • 799 Topics
  • 6358 Solutions
Registered:

@RustyKnight 

I get exactly the same as you on my Windows laptop. I can sign in then get this

security check.JPG

As you see, no space to put in the code which has been sent to my phone. However when I look at the top of this page, I see this (Note the highlighted section at the top)

Security check 2.JPG

So I just click on this link https://community.o2.co.uk/ and it brings up my home page for the forum!

A real pain but at least we can get on the forum. 10 days ago, most of us couldn't get on, no matter what we tried!

*The Game Is On*

Girl in a jacket
Message 3 of 16
167 Views

TallTrees
Level 45: Knowing
  • 8632 Posts
  • 82 Topics
  • 255 Solutions
Registered:

Yes @RustyKnight 

I got the message too. First time I was logged in anyway.  The second time it was very clear and all went well. I got the code to phone put in box and then got access. Although it may be a bit of a palaver, extra security is good and I fully support more security and more care.  



HAPPINESS IS BEE SHAPED

Message 4 of 16
164 Views

Cleoriff
  • 110661 Posts
  • 799 Topics
  • 6358 Solutions
Registered:

@TallTrees 

I agree, extra security is good (WHEN IT WORKS Lol) As you see on my laptop image, there is no box to put the code in?! So it's pointless when actually as my second image shows, I am actually signed in without the code.

Something twisted with the system I think.

*The Game Is On*

Girl in a jacket
Message 5 of 16
160 Views

RustyKnight
Level 1: Joiner
  • 4 Posts
  • 1 Topics
  • 0 Solutions
Registered:

Now I'm having problems logging in to reply!

 

I'm using a PC with Chrome, haven't tried on anything else.

Thanks for the replies - good to hear its not just me.

Message 6 of 16
149 Views

pgn
Level 61: Brainiac
  • 23295 Posts
  • 172 Topics
  • 578 Solutions
Registered:

One further thing that *might* work - have you tried accessing the forum from an Incognito tab in your browser?  And ditto from a new Incognito window for O2.co.uk main site?

The problem seems to stem from both Forum and main O2 website using the same authentication system.

Forum: https://community.o2.co.uk/

Site: https://o2.co.uk

 

Worth a shot, @RustyKnight.

O2CommunityAwardNotCS




O2 Social Media
SM Icons(Twitter | Instagram | Facebook)















Message 7 of 16
144 Views

RustyKnight
Level 1: Joiner
  • 4 Posts
  • 1 Topics
  • 0 Solutions
Registered:

That seems to work, except it asked me to change my password and now says my new password isn't recognised so I had to make another new one.

Message 8 of 16
136 Views

pgn
Level 61: Brainiac
  • 23295 Posts
  • 172 Topics
  • 578 Solutions
Registered:

Once the password is changed and you login normally again, the box prompt, without a box, should go away.

O2CommunityAwardNotCS




O2 Social Media
SM Icons(Twitter | Instagram | Facebook)















Message 9 of 16
130 Views

TallTrees
  • 8632 Posts
  • 82 Topics
  • 255 Solutions
Registered:

@Cleoriff 

Yes it is dodgy, hope it gets up and running smoothly before too long.

 



HAPPINESS IS BEE SHAPED

Message 10 of 16
122 Views