cancel
Showing results for 
Search instead for 
Did you mean: 

Samsung Galaxy Watch 4 "Emergency Calls Only" Fix

Ian_McD
Level 1: Joiner
  • 2 Posts
  • 1 Topics
  • 0 Solutions
Registered:

If you're on O2 and you're getting "Emergency Calls Only" on your watch when out of range of your phone here's the fix!

 

I know this is a big problem for a lot of people, some of whom have returned their watch because they can't get it to work. I've detailed the process right from the start for the benefit of people who have come straight to this thread and may not have already tried most of the suggestions on other threads, most of which are relevant.

 

This guide assumes that you have already set up your eSim via the Galaxy Wearable App. Go in the following order:

 

Settings On Your Phone

1) Settings> Advanced Features> Call And Text On Other Devices - Enable

 

Settings On Your Watch

1) Settings> Connections> Mobile Networks> Select Auto  (Always On can be selected but Auto works fine and is better for battery life).

 

Go To The Wearable App On Your Phone

1) Watch Settings> Advanced Features> Remote Connection Turn On - Enable

Now here's the bit where I think it goes wrong for most people not being aware of this next step.

2) Where you just enabled the Remote Connection, stay there but this time tap on the text that says "Remote Connection" rather than selecting the toggle switch.

3) You will now enter a sort of hidden menu that contains a switch called "Calling" and it says "Make and receive calls on your watch without a Bluetooth connection to your phone". This needs to be enabled. It takes a few seconds to activate.

 

Now to test your connection.

1) Your phone must be on and connected to your phone data plan or wifi.

2) Make sure your Bluetooth is switched on on your phone. Although it is not being used turning it off disables most of the features in the Wearable App including what you need for this to work!

3) You can now turn off the Bluetooth on your watch to simulate being away from your phone (or you could go for a walk and leave your phone at home!). Give it a few seconds while the phone switches over to the network (a little cloud should appear on the watch face), mine takes about fifteen seconds to switch over.

4) Make your call. Hopefully if all is well you should be good to go!

 

Good luck! I came within a whisker of returning my phone after numerous visits to the O2 Shop and hours of messing about simply because of the hidden setting under the "Remote Connection" settings that I only found by accident!

5 Comments