cancel
Showing results for 
Search instead for 
Did you mean: 

New Apple Watch Series 6 upgrade not connecting to cellular plan

jordmagx
Level 1: Joiner
  • 4 Posts
  • 2 Topics
  • 0 Solutions
Registered:
Hi there,

Apologies if this has already been a topic but I couldn’t find anything as specific as my problem.

I have iPhone XR.
Apple Watch Series 6 with unlimited cellular plan.

I’ve had an Apple Watch Series 3 with cellular which worked flawlessly for two years. Last week I upgraded to the Series 6 and kept the cellular plan. Since the upgrade, the cellular plan has not worked without the iPhone connected. When I leave the iPhone behind, the Watch displays a disconnected warning.

I’ve checked that all software is up to date, I’ve unpaired and repaired the devices and have asked o2 for their help and they’ve reset thr eSIM, with nothing working.

When I go into the control centre on the watch, it says the data plan is on and working fine, but when disconnected from the iPhone, there is no cellular service (no little dots indicating signal for example). When I go into the iPhone Watch app and go to Mobile Data, it says o2 with a little orange ‘I’ beside it, indicating that the cellular plan is active.

So why isn’t it working when the iPhone isn’t present?

Any wisdom would be much appreciated as things like this really frustrate me when you feel like you’ve tried all fixes suggested to you!

Thank you,
Jordan.
Message 1 of 4
787 Views
3 REPLIES 3

MI5
Level 94: Supreme
  • 128216 Posts
  • 614 Topics
  • 22519 Solutions
Registered:

@jordmagx 

The only 2 things I can think are, 

1 your old watch is still registered on the system and is in conflict with the new one.

2 the new watch is faulty.

Start by asking O2 to check and remove your old one from your account.

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 2 of 4
781 Views

TheresaV
Former Staff
  • 1930 Posts
  • 80 Topics
  • 12 Solutions
Registered:

Hi @jordmagx did you find out the issue behind your Apple Watch disconnecting?

COVID-19 support - Help and support from O2 during the lockdown
Access for You: Registration - Find out how to register for our Access for You service.
Just joined the community or thinking of registering? Check out this handy starter guide!
Have a query about your account? login to My O2 for help


If you'd like to take part, why not register? slight_smile
signature

Message 3 of 4
620 Views

jordmagx
Level 1: Joiner
  • 4 Posts
  • 2 Topics
  • 0 Solutions
Registered:
Still nothing. Went back to o2 and they replaced the watch, the cellular reactivated today and still when the phone isn’t with me, the watch shows disconnected when I swipe up the control centre and the cellular icon remains white. Very frustrating when it says mobile data is connected on the watch app and o2 insist everything looks fine on their side but the cellular is still not working.
Message 4 of 4
605 Views