cancel
Showing results for 
Search instead for 
Did you mean: 

Galaxy S6 and car connectivity

Anonymous
Not applicable

Hi, I have a brand new VW Touran with a factory fitted car kit, and dealer fitted Kenwood multimedia/navigation system. Both of which I was able to connect and sync with using Bluetooth from my S4.

 

But then I upgraded to the S6.

 

Car kit - I can connect fine, sync address book, and dial out... but, no sound from either car audio or handset. I've tested this out with my home phone. The call is ringing out, and connecting but is muted. Same goes for incoming calls. No sound. Is there a secret setting hidden away, or am I just holding my mouth wrong?

 

Multimedia system (Kenwood DNX525DAB). Again worked with the S4. I had successful upgraded the Bluetooth firmware on the DNX5 and this was working fine with the S4. The S6, a different story. Both devices pair okay, but the options for what can be accessed by the DNX5 continually change. Invariably they turn themselves off. I can enable phone and media from both devices, but the S6 keeps turning them off. I slide the button across to enable, it stays on very briefly then slides straight back. Very very occasionally they stay on, and I can stream music from my phone to the DNX5, and also I have been able to receive and make calls from the DNX5 unit (which isn't accessible from the phone controls on the steering wheel, great for laybys but not for answering calls whilst driving - hence wanting to use via car kit). 

 

The DNX5 unit has a Garmin navigation system built in. Apparently I can use Garmin Smartlink from the S6 to update the satnav on the hoof about traffic, weather and roadworks.  This was something I never tried with my trusty S4. The S6 shows that it is connected  (sometimes! ) to the satnav using smartlink, but the satnav is showing no connection. Again another Bluetooth issue.

 

So in a nutshell, I'm guessing that the issue lies with the Bluetooth on my S6. Is there a fix? I hope so, because as it stands I really regret upgrading to the S6.

 

 

Message 1 of 11
7,807 Views
10 REPLIES 10

Cleoriff
Level 94: Supreme
  • 112404 Posts
  • 801 Topics
  • 6693 Solutions
Registered:

Hi @Anonymous

Welcome to the forum. I will leave this issue with bluetooth to someone more technically able than me. I have no problems with my Note 3 in my Ford ...but then my other half set it up for me....:smileywink:

I doubt it's anything to do with you  "holding your mouth wrong"  (your words) Smiley Very Happy

Veritas Numquam Perit

Girl in a jacket
Message 2 of 11
7,772 Views

Bambino
Level 78: King of Kings
  • 19873 Posts
  • 961 Topics
  • 2844 Solutions
Registered:

Might be an idea to speak to Samsung technical support directly, and also to your VW dealer. It may be a problem they already know about.

I DO NOT WORK FOR O2



Funniest-Thread-2
Message 3 of 11
7,768 Views

MI5
Level 94: Supreme
  • 128140 Posts
  • 614 Topics
  • 22494 Solutions
Registered:
Have you checked for any software updates on the phone?
5.0 did have some BT issues but should have been fixed in 5.1
I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 4 of 11
7,759 Views

Anonymous
Not applicable
Hi, yes using 5.1.1 so all up to date on the phone. Biggest frustration is there are too many different tech companies involved. VW, Kenwood, Garmin and Samsung. Awaiting answers from VW and Kenwood. Browsing various car forums there are quite a number of S6 threads describing how the BT connection keeps being forgotten, autoconnect not working once devices have paired. Unfortunately no consistent solutions, and none that I have found have worked so far.(Most solutions involve deleting pairing, rebooting then re -pairing devices).

Coupled with woeful battery life, recurring 999 calls only when showing full signal strength, apps opening and closing by themselves... I'm almost wishing I had gone over to the Darkside and got an iPhone
Message 5 of 11
7,749 Views

MI5
Level 94: Supreme
  • 128140 Posts
  • 614 Topics
  • 22494 Solutions
Registered:
With the added info about other issues you are having I would suggest you might have a faulty device.
TBH, I'd contact Samsung and get them to check it out for you.
I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 6 of 11
7,741 Views

ewanrw
Level 10: Inspirational
  • 342 Posts
  • 15 Topics
  • 9 Solutions
Registered:

I'm going with the Kenwood not supporting the newer model as I've experienced it before with a Kenwood head unit supporting the iPhone 4S, but not the iPhone 5.

 

Edit:

 

And if you check here, it looks as tho' the S6 isn't supported.

 

ewan

Message 7 of 11
7,685 Views

Anonymous
Not applicable

Whilst it does not  list the S6, the original manual which came with the DNX525 does not list the S4 nor the S5. The DNX525 has had a firmware update and BT update and worked flawlessly with my S4. The S4 listing has only recently been added.  So whilst logic might point that direction, I'm not wholly convinced.

 

Update: after a very long drawn out phone conversation with Samsung support, sadly the young man I initially spoke to CBA to offer any other solution than "do a factory reset", I spoke to his supervisor who said that the techies needed a look at it. So now my S6 resides at the local Samsung hospital. O2 were very helpful in sorting out a new sim card, so now back on my S4 (which works! That's all I want the newer, slightly better model to do.). If the Samsung hospital can't resolve the issues, the woeful thing is going on fleabay and I shall be going over to the Darkside.

Message 8 of 11
7,637 Views

MI5
Level 94: Supreme
  • 128140 Posts
  • 614 Topics
  • 22494 Solutions
Registered:
Was the firmware update after the S6 was launched, or before?
I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 9 of 11
7,633 Views

Anonymous
Not applicable

Kenwood firmware was Jan this year. They have told me that the official line is that it does not have compatability with the S6, however it should work, but they can't  guarantee that.

 

Phone has come back from repair. When I say my phone, only my screen has come back, pretty much everything else has been replaced. Initial impressions are it seems to be working. I will comment further, after a day of fiddling! Thanks for the help so far.

Message 10 of 11
7,564 Views