Welcome to the O2 Community

Has your question already been answered? See the community FAQ's

Welcome & News

Reply
Highlighted
O2 Social Media Team
Posts: 1,345
Registered: ‎27-11-2013

Android 4.0 - New Minimum for TU Go

[ Edited ]

Hey all,

 

We wanted to keep you updated on some changes we're making to TU Go for Android.

 

We're changing our minimum supported version of Android from 2.3 to 4.0. If you're one of the <2% of TU Go users that will be affected by this, the current version of TU Go should still work for you, but we can no longer guarantee the availability or quality of the TU Go service on these unsupported legacy operating systems.

 

Why are we doing this?

Doing this will save us considerable development and testing overheads on legacy operating systems (which also tend to be more prone to bugs/issues) and will allow us to focus on building an ever higher quality service for customers using Android 4.0 and above.

 

We understand that for a small number of customers this may be disappointing. If you're running Android 2.3 or 3.x, you may be able to upgrade it to Android 4.0 - Check in your settings if you have this available. If you do not, TU Go is also available on desktop web browsers using the latest version of Chrome or Firefox. You can also use TU Go on any iOS 5.0+ or Windows Phone 8.0+ device.

 

If you’re one of those affected, you’ll receive a text from us in the coming days with further details.


Hi. I'm from the Social Media Team.

Highlighted
Posts: 94,392
Topics: 541
Registered: ‎04-04-2012

Re: Android 4.0 - New Minimum for TU Go

[ Edited ]

I can see the sense in this decision but can't help thinking it's gonna annoy a few people - I'm sure we'll hear about it on here though.......

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Highlighted
Posts: 75,190
Topics: 559
Registered: ‎04-01-2009

Re: Android 4.0 - New Minimum for TU Go

As long as the previous version works for them, otherwise there may well be some annoyed customers on here.

Incidentally another update today....bug fixes again.

Now version v.2.25.0 

Highlighted
O2 Social Media Team
Posts: 1,345
Registered: ‎27-11-2013

Re: Android 4.0 - New Minimum for TU Go


@MI5 wrote:

I can see the sense in this decision but can't help thinking it's gonna annoy a few people - I'm sure we'll hear about it on here though.......


In terms of stats, this will impact less than 2% of our TU Go users - and believe it or not the Android 3.x users that have TU Go equates to approx 0.007% - yep, that figure is real. We understand it may cause some disappointment for those users and we hope they're still able to make use of the app - it just won't be updated with any new features or bug fixes.


Hi. I'm from the Social Media Team.

Highlighted
Posts: 94,392
Topics: 541
Registered: ‎04-04-2012

Re: Android 4.0 - New Minimum for TU Go

Fair enough then really.
Makes no sense to keep developing - Hopefully that means more time can be spent improving the current version?
I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Highlighted
Posts: 75,190
Topics: 559
Registered: ‎04-01-2009

Re: Android 4.0 - New Minimum for TU Go

The last three updates have been bug fixes. Could the developers please sort out some new features, particularly receiving short code text messages and fuller integration with the phone's os.

Highlighted
Former Staff
Posts: 11,573
Registered: ‎13-08-2012

Re: Android 4.0 - New Minimum for TU Go


@jonsie wrote:

The last three updates have been bug fixes. Could the developers please sort out some new features, particularly receiving short code text messages and fuller integration with the phone's os.


Hi @jonsie, we're working hard to see if we can share any info on upcoming feature additions and functionality. and I'll share anything I can.

Fancy writing a great device review or O2 forum guide? Send me a message!

Get involved:
• New to the community? This is how you get help.
• Want to know who we are? Come and say hi to us.
• Want to have a chat? Drop me a direct message.

Highlighted
Posts: 94,392
Topics: 541
Registered: ‎04-04-2012

Re: Android 4.0 - New Minimum for TU Go


@jonsie wrote:

The last three updates have been bug fixes. Could the developers please sort out some new features, particularly receiving short code text messages and fuller integration with the phone's os.


Number blocking would be good too.

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)