cancel
Showing results for 
Search instead for 
Did you mean: 

Wrong number showing on Sent text messages

Nufkamp
Level 1: Joiner
  • 5 Posts
  • 1 Topics
  • 0 Solutions
Registered:
I set up my new phone yesterday and ported my old number across. If I send a text it shows it as coming from the number on the sim prior to my number porting across. I can receive texts to my ported number, and calls correctly show my ported number, it's just text messages that show the wrong number. Any advice?
Message 1 of 10
404 Views
9 REPLIES 9

Cleoriff
Level 94: Supreme
  • 106523 Posts
  • 790 Topics
  • 5534 Solutions
Registered:

@Nufkamp 

When porting across, text numbers are usually the last thing to work properly. Keep rebooting your phone.

*The Game Is On*

Girl in a jacket
Message 2 of 10
397 Views

Nufkamp
Level 1: Joiner
  • 5 Posts
  • 1 Topics
  • 0 Solutions
Registered:
Ok, thank you. I will give this a try for a few days.
Message 3 of 10
392 Views

MI5
Level 94: Supreme
  • 122472 Posts
  • 609 Topics
  • 19144 Solutions
Registered:

@Nufkamp 

Settings >Phone >My number.

Change it to your number, save it and reboot phone. 

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 4 of 10
376 Views

Nufkamp
Level 1: Joiner
  • 5 Posts
  • 1 Topics
  • 0 Solutions
Registered:
There is nothing under the settings where I can do this, neither in Message settings or the About Phone setting.
Message 5 of 10
372 Views

MI5
Level 94: Supreme
  • 122472 Posts
  • 609 Topics
  • 19144 Solutions
Registered:

@Nufkamp 

What phone have you got?

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 6 of 10
364 Views

Nufkamp
Level 1: Joiner
  • 5 Posts
  • 1 Topics
  • 0 Solutions
Registered:
Samsung S21
Message 7 of 10
362 Views

MI5
Level 94: Supreme
  • 122472 Posts
  • 609 Topics
  • 19144 Solutions
Registered:

Should be in message settings either under general or SIM or advanced RCS settings.

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 8 of 10
358 Views

Nufkamp
Level 1: Joiner
  • 5 Posts
  • 1 Topics
  • 0 Solutions
Registered:
I have found the (a?) solution, certainly the correct number is now being shown to the recipient. I went to Settings >Chat Settings and changed Default Messaging Type from Chat to Text or Multimedia.
Message 9 of 10
347 Views

MI5
Level 94: Supreme
  • 122472 Posts
  • 609 Topics
  • 19144 Solutions
Registered:
It's the chat setting that uses the number stored on your phone.
I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 10 of 10
342 Views