cancel
Showing results for 
Search instead for 
Did you mean: 

Samsung Galaxy Watch 3 Unable To Call / Text.

danbutterworth
Level 1: Joiner
  • 9 Posts
  • 2 Topics
  • 0 Solutions
Registered:
I have just got the Galaxy Watch 3, love it apart from a small problem.

I have installed the Samsung app and configured it all and the watch has a 4G plan which costs £5 a month. I was under the impression that when the watch is away from the phone I could call and text with the same number as my phone. When out of range it just asks if I want to connect via Bluetooth.

I have hard reset the watch, and configured it as a stand alone device with it's own 4G connection, but this is for the number allocated to the watch which I don't want. Once configured like this, the watch does have an active 4G connection.

So in short, when configured via Bluetooth to my phone it all works perfectly with notifications etc, once out of Bluetooth range can't call/text etc.

It's paired to a Sony Xperia 3 under Android version 10.

Thank you!
Message 1 of 13
442 Views
12 REPLIES 12

MI5
Level 94: Supreme
  • 120693 Posts
  • 605 Topics
  • 18166 Solutions
Registered:

@danbutterworth 

It has to use it's own number but will still work with your phone when out of range this way.

It's because you can't have 2 sims with the same number on them.

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 2 of 13
400 Views

madasaf1sh
Level 53: Renowned
  • 3367 Posts
  • 24 Topics
  • 734 Solutions
Registered:
@danbutterworth

You need to ensure remote connections is turned on, from within the Galaxy Wearables App.

When this is enabled the watch will send messages as if from your phone.

The number of your watch is only for Data, and nothing else.

https://www.youtube.com/watch?v=UMTtbe5aKv0

And move to 28minutes and onwards will help
Current Phone: Motorola Razr 5g
I also have a Planet Computers Gemini

I work in IT as an Enterprise Messaging and Collaboration Tools Administrator (Office 365, Slack and much much more) and manage hardware both Mobile and Desktop / laptop, my desk is a bit like PC World

--
We are all customers and dont have access to any o2 accounts





Message 3 of 13
389 Views

danbutterworth
Level 1: Joiner
  • 9 Posts
  • 2 Topics
  • 0 Solutions
Registered:
Ah, got it, I think I'm winning here. When I'm away from the phone (which I leave on obviously), everything seems to work (notifications, texts send and receive etc) but won't let me make calls. Def connected to 4G, just says "Connect via Bluetooth" with a "x" and a tick. Also, when someone rings my phone it rings, but watch doesn't!

Thank you for your help so far, greatly appreciated!
Message 4 of 13
377 Views

MI5
  • 120693 Posts
  • 605 Topics
  • 18166 Solutions
Registered:

@danbutterworth 

Do you have wifi calling enabled on your account?

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 5 of 13
359 Views

danbutterworth
Level 1: Joiner
  • 9 Posts
  • 2 Topics
  • 0 Solutions
Registered:
I have WiFi calling enabled on the phone if that makes any difference?
Message 6 of 13
347 Views

MI5
  • 120693 Posts
  • 605 Topics
  • 18166 Solutions
Registered:

@danbutterworth wrote:
I have WiFi calling enabled on the phone if that makes any difference?

Yes, it's required.

Does it actually work though?

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 7 of 13
342 Views

danbutterworth
Level 1: Joiner
  • 9 Posts
  • 2 Topics
  • 0 Solutions
Registered:
Nope!

I spoke to Samsung tech support, they soon gave up and said watch was faulty. Told O2 and they kindly replaced it the next day.

Where I am now is when out of Bluetooth range the watch connects happily to the 4G network, get notifications etc and can even send and receive texts (via my phone number) and says "connected remotely" but when I try to call it just says "Connect via Bluetooth?" with a cross and a tick. Push the tick it obvious hunts for my out of range phone and goes back to the phone screen and obviously the cross does the same.

I really can't help but think I've missed something really obvious!

Thank you!
Message 8 of 13
325 Views

danbutterworth
Level 1: Joiner
  • 9 Posts
  • 2 Topics
  • 0 Solutions
Registered:
@MI5 just read the troubleshooting bit of the manual, surely this can't be right?!

Ensure that your Galaxy Watch3 is connected to a mobile device via Bluetooth. If your Galaxy Watch3 is connected to your mobile device remotely, you cannot receive incoming calls.
Message 9 of 13
317 Views

MI5
  • 120693 Posts
  • 605 Topics
  • 18166 Solutions
Registered:

@danbutterworth 

Just noticed there are 2 threads running so a bit confusing, but you need to tick the phone setting to allow calls on other devices but it will only work over 4g when you have wifi and 4g calling enabled and working on your account.

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 10 of 13
310 Views