cancel
Showing results for 
Search instead for 
Did you mean: 

P20 Pro - no option for Wifi Calling

Mosmordor
Level 1: Joiner
  • 10 Posts
  • 3 Topics
  • 0 Solutions
Registered:

Hi folks,

 

I have a P30 Pro and P20 Pro, both on o2 pay monthly. The P30 Pro has a wifi calling option with no problem, however the P20 Pro doesn't show this option in the settings menu.

 

I have checked on the web portal and it shows wifi calling is enabled, so everything should be set up properly. Any way I can force a refresh/update of my settings to show the wifi calling option?

 

Thank you!

Message 1 of 12
524 Views
11 REPLIES 11

Bambino
Level 77: Grand Master
  • 19540 Posts
  • 954 Topics
  • 2691 Solutions
Registered:

@Mosmordor If that phone is on O2's approved list you need to get customer service to enable WiFi calling from their end. Call 202 from your mobile, or 0800 032 1402.

When it comes to the reason you are calling, stay silent for 15 seconds and you will be taken to the keypad options.
Press 2 for Everything Else
Press 5 for More Options
Press 7 for Anything Else which will put you though to someone.

8 am is the best time to call.

I DO NOT WORK FOR O2



Funniest-Thread-2
Message 2 of 12
458 Views

Mosmordor
  • 10 Posts
  • 3 Topics
  • 0 Solutions
Registered:
Thanks Bambino! I actually did call them last week and they enabled it, could it be they didn't do it right?
Message 3 of 12
457 Views

Bambino
Level 77: Grand Master
  • 19540 Posts
  • 954 Topics
  • 2691 Solutions
Registered:

Anything is possible, @Mosmordor. It's a pain, I know, but you'll have to call again. Good luck.:smileywink:

I DO NOT WORK FOR O2



Funniest-Thread-2
Message 4 of 12
454 Views

Mosmordor
  • 10 Posts
  • 3 Topics
  • 0 Solutions
Registered:

Hi all - we called up o2 and were informed that Wifi and 4G calling are already enabled, still not showing the option on the phone for some reason though 😞

Message 5 of 12
440 Views

MI5
Level 94: Supreme
  • 126820 Posts
  • 613 Topics
  • 21775 Solutions
Registered:

@Mosmordor 

Have you rebooted the phone?

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 6 of 12
437 Views

Mosmordor
Level 1: Joiner
  • 10 Posts
  • 3 Topics
  • 0 Solutions
Registered:
Hey MI5 - yeah we've tried:

- resetting network settings
- updating OS to android 10
- rebooting phone
- SIM card in slot 1 and 2

O2 are trying to remove the setting and reapply it from the account to see if it comes through.
Message 7 of 12
430 Views

MI5
Level 94: Supreme
  • 126820 Posts
  • 613 Topics
  • 21775 Solutions
Registered:

You need to give it 24 hours after they have enabled it and then reboot again @Mosmordor 

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 8 of 12
424 Views

Mosmordor
Level 1: Joiner
  • 10 Posts
  • 3 Topics
  • 0 Solutions
Registered:
Thanks MI5 for your answers. Still no luck I'm afraid!

Is there any way to force this option to show up on the phone, or for o2 to force the phone to recognise the setting should be enabled? 😞
Message 9 of 12
398 Views

MI5
Level 94: Supreme
  • 126820 Posts
  • 613 Topics
  • 21775 Solutions
Registered:

Is your phones software up to date @Mosmordor ?

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 10 of 12
396 Views