cancel
Showing results for 
Search instead for 
Did you mean: 

PAYG text messages cost tons every time - why?

CC81
Level 1: Joiner
  • 6 Posts
  • 1 Topics
  • 0 Solutions
Registered:

Hello, I hope someone can help!

 

I have an O2 SIM that I mostly use for incoming calls.

 

Occasionally (maybe 1-2 times a week) I send a text message.

 

Each time (for one message), I get about 5 notifications about deductions from my allowance - often up to a total of £1.

 

According to my standard charges, each text message sent should only cost 15p.

 

Why is it costing so much more each time? They're not iMessages or picture messages.  I don't use any other apps; and WiFi, Bluetooth and Mobile Data are all turned off.

Is there any way I can find out what charges are being applied to my phone; and why?

Message 1 of 13
488 Views
1 ACCEPTED SOLUTION

Accepted Solutions

jonsie
Level 94: Supreme
  • 86931 Posts
  • 594 Topics
  • 5106 Solutions
Registered:

This happens when messaes are particularly long or include  multiple emojis

Guide: Accidental MMS Sending and How to Avoid it 

2020-Awards-jonsie5695219-2




O2 Social Media

SM IconsTwitter

Instagram

Facebook




View solution in original post

Message 3 of 13
416 Views
12 REPLIES 12

MI5
Level 94: Supreme
  • 127410 Posts
  • 614 Topics
  • 22123 Solutions
Registered:

@CC81 

Your phone must be sending the message 5 times or to 5 different people?

If you're only intending to send one message to one person, try turning off and removing your sim.

Give it a wipe with a dry cloth and clean the contacts with a pencil eraser, then refit sim and try again.

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 2 of 13
431 Views

jonsie
Level 94: Supreme
  • 86931 Posts
  • 594 Topics
  • 5106 Solutions
Registered:

This happens when messaes are particularly long or include  multiple emojis

Guide: Accidental MMS Sending and How to Avoid it 

2020-Awards-jonsie5695219-2




O2 Social Media

SM IconsTwitter

Instagram

Facebook




Message 3 of 13
417 Views

CC81
Level 1: Joiner
  • 6 Posts
  • 1 Topics
  • 0 Solutions
Registered:

Nope - just one message and one number each time. It's weird!

Message 4 of 13
396 Views

CC81
Level 1: Joiner
  • 6 Posts
  • 1 Topics
  • 0 Solutions
Registered:

@jonsie wrote:

This happens when messaes are particularly long or include  multiple emojis

Guide: Accidental MMS Sending and How to Avoid it 


This might be it! Thank you. No emojis, but the messages are probably longer than standard.

Does anyone know how to turn off MMS on an iPhone?

 

I've found the APN settings, but no option to edit them...

Message 5 of 13
393 Views

MI5
Level 94: Supreme
  • 127410 Posts
  • 614 Topics
  • 22123 Solutions
Registered:

There is a settings in the messages section to turn off mms but also try cleaning the sim @CC81 and if that doesn't help, ask O2 on 4445 to check if you're setup OK.

The messages would have to be very long to convert into mms.

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 6 of 13
391 Views

CC81
Level 1: Joiner
  • 6 Posts
  • 1 Topics
  • 0 Solutions
Registered:

@MI5 wrote:

There is a settings in the messages section to turn off mms but also try cleaning the sim @CC81 and if that doesn't help, ask O2 on 4445 to check if you're setup OK.

The messages would have to be very long to convert into mms.


Thanks - I'm going to try to resolve the 'accidental MMS' thing first, plus SIM cleaning... then if no luck, will ask O2 what's going on.

 

Just need to figure out how to change the MMS settings on an iPhone, as I've said above.

Message 7 of 13
385 Views

jonsie
Level 94: Supreme
  • 86931 Posts
  • 594 Topics
  • 5106 Solutions
Registered:
  1. Tap Settings.
  2. Scroll down and tap Advanced.
  3. Switch Auto-download MMS to Off.
2020-Awards-jonsie5695219-2




O2 Social Media

SM IconsTwitter

Instagram

Facebook




Message 8 of 13
382 Views

MI5
Level 94: Supreme
  • 127410 Posts
  • 614 Topics
  • 22123 Solutions
Registered:

@CC81 

Settings >Messages >MMS Messaging - Turn slider off

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 9 of 13
381 Views

CC81
Level 1: Joiner
  • 6 Posts
  • 1 Topics
  • 0 Solutions
Registered:

@MI5 wrote:

@CC81 

Settings >Messages >MMS Messaging - Turn slider off


The slider is already off, within the Messages settings, so that can't be it.

But the other poster has mentioned changing the APN settings - is this different? There's no option to edit.

Message 10 of 13
374 Views