cancel
Showing results for 
Search instead for 
Did you mean: 

Data usage (Roaming)

August
Level 1: Joiner
  • 2 Posts
  • 1 Topics
  • 0 Solutions
Registered:

Hi, I am currently on the £10 bundle and I still have data but I am finding it difficult to use it now that I am in Germany. Is there something I need to do to be able to use my data? 

Or is my bundle not big enough to roam with my data as I was able to use it in Amsterdam. 

And I do not need to use 02 travel.

Message 1 of 3
100 Views
1 ACCEPTED SOLUTION

Accepted Solutions

MI5
Level 94: Supreme
  • 120736 Posts
  • 605 Topics
  • 18184 Solutions
Registered:

@August 

You can roam in Germany fine as long as you have data remaining on your bundle?

Some things to try.
1 - Manually search for a different network.
2 - Reboot your phone
3 - Call customer service to check for any roaming bars.
4 - If using an iPhone, change data apn to "mobile.o2.co.uk"

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)

View solution in original post

Message 2 of 3
84 Views
2 REPLIES 2

MI5
Level 94: Supreme
  • 120736 Posts
  • 605 Topics
  • 18184 Solutions
Registered:

@August 

You can roam in Germany fine as long as you have data remaining on your bundle?

Some things to try.
1 - Manually search for a different network.
2 - Reboot your phone
3 - Call customer service to check for any roaming bars.
4 - If using an iPhone, change data apn to "mobile.o2.co.uk"

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)

View solution in original post

Message 2 of 3
85 Views

August
Level 1: Joiner
  • 2 Posts
  • 1 Topics
  • 0 Solutions
Registered:

Thanks for your reply. Did all that but didn't work. Later realized I had to change the access point name to O2 Pay & Go. That finally worked. Appreciate your response.

Message 3 of 3
65 Views