Welcome to the O2 Community

Has your question already been answered? See the community FAQ's

Other Products and Services

Reply
Anonymous
Posts: 0

No Networks Available On Laptop But Working Fine On PC

Hi, I wonder if anyone can help me?

I have been using my PAYG dongle for a year now on both my PC (XP) and laptop (Vista). In the last week I have suddenly been unable to connect to mobile broadband via the laptop. When I load connection manager it tells me that there are no available networks yet if I unplug the dongle and put it in the PC, it works fine.

I have installed the latest drivers and connection manager software on the laptop and it still refuses to work. As the dongle will work on the PC I know there is no problem with the dongle or my reception.

Has anybody else encountered this problem or have any suggestions on how to solve it?

Any help greatly appreciated.
Highlighted
Posts: 27,019
Topics: 247
Solutions: 1,614
Registered: ‎29-07-2008

No Networks Available On Laptop But Working Fine On PC

Try following the fix given by Sharon@O2 at the top of the forum.

I hope this helps you.
To support Disasters Emergency Committee: http://www.dec.org.uk/appeals text Nepal to 70000 to send £5

Sky Unlimited Broadband - Windows 10 - Nexus 4 Android 5.1.1
Anonymous
Posts: 0

No Networks Available On Laptop But Working Fine On PC

Try following the fix given by Sharon@O2 at the top of the forum.
I hope this helps you.


I tried that but it was no help.

I resolved the problem in the end by uninstalling the modem via device manager.
Posts: 27,019
Topics: 247
Solutions: 1,614
Registered: ‎29-07-2008

No Networks Available On Laptop But Working Fine On PC

Well done, sorry I couldn't help you.
To support Disasters Emergency Committee: http://www.dec.org.uk/appeals text Nepal to 70000 to send £5

Sky Unlimited Broadband - Windows 10 - Nexus 4 Android 5.1.1
Level 9: Fired up
Posts: 1,487
Registered: ‎14-09-2010

No Networks Available On Laptop But Working Fine On PC

I get this most days, if I boot the computer with the dongle plugged in it works but plugging it in whilst Windows is running nearly always results in no networks found.