cancel
Showing results for 
Search instead for 
Did you mean: 

4G & Wi-fi Calling enable

GMF
Level 2: Apprentice
  • 10 Posts
  • 1 Topics
  • 1 Solutions
Registered:

I (and Customer Services) have a problem getting these services up and running on my new O2 Sim only contract (with ported in number from Vodafone).  I've enabled the service in MyO2.  All other services, including 4G (VoLTE Off) and Wifi work normally.

On my iPhone 11 Pro Max, when I attempt to select the "4G, VoLTE On" option I get the following error back "Cannot Activate 4G Calls, To enable 4G calls on this account, contact O2."   When I attempt to enable Wif-Fi calling I get this message "Wi-Fi Calling, To allow Wi-Fi calling on this account, contact O2."

I have tried the usual rebooting of the phone, resetting network settings and checking the apn details are correct.  I have also tried the sim in a Samsung Galaxy S8+, but the option to enable 4G calling is greyed out.  I've also been on different cell sites and different Wi-fi networks.

An O2 Guru tried removing the service from my account and then adding it again, but again this didn't make the service available on either device.  This has now exhausted the help O2 Customer Services can offer so I'm wondering if the wider community has any helpful ideas before I go grovelling back to Vodafone...

 

 

Message 1 of 20
1,513 Views
1 ACCEPTED SOLUTION

Accepted Solutions

GMF
Level 2: Apprentice
  • 10 Posts
  • 1 Topics
  • 1 Solutions
Registered:

Morning @MI5 and @O2John 

 

Having done my morning reboot of my phone, I can confirm that both elements are now correctly working!  Whether time, the great healer, or Cust Services fixed it, I can't be sure.   

 

I hope other customers experiencing this problem after a port-in have had their service fixed and get reassurance that they don't have a problem with their iPhones and that it can be resolved successfully.

 

However, @O2John , please send my apologies to your gut as it failed you on this one 😛

View solution in original post

Message 16 of 20
1,066 Views
19 REPLIES 19

MI5
Level 94: Supreme
  • 120725 Posts
  • 605 Topics
  • 18184 Solutions
Registered:

@GMF 

What device does it say you are using in your MtO2 http://www.o2.co.uk/myo2 ?

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 2 of 20
1,321 Views

GMF
Level 2: Apprentice
  • 10 Posts
  • 1 Topics
  • 1 Solutions
Registered:

Hi @MI5, thanks for getting back to me slight_smile

 

I'm not sure if i'm looking on the right page, but I haven't found anywhere in MyO2 that it says the device i'm using.

 

edit:  the iPhone bolt on was confirmed as being active by Customer Services, though

Message 3 of 20
1,310 Views

MI5
Level 94: Supreme
  • 120725 Posts
  • 605 Topics
  • 18184 Solutions
Registered:

@GMF 

Top left below your phone number.

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 4 of 20
1,299 Views

GMF
Level 2: Apprentice
  • 10 Posts
  • 1 Topics
  • 1 Solutions
Registered:

I just have placeholder text "Set a device name" and a little pen icon.

 

Just spotted there's another member @joenitro  on the Pay Monthly boards having what appears to be the same problem, although my port was a few days earlier.

Message 5 of 20
1,295 Views

MI5
Level 94: Supreme
  • 120725 Posts
  • 605 Topics
  • 18184 Solutions
Registered:

Sounds like the problem then in that no device has registered on the system yet @GMF 

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 6 of 20
1,291 Views

GMF
Level 2: Apprentice
  • 10 Posts
  • 1 Topics
  • 1 Solutions
Registered:

Interesting.

Well, I'll give it a couple more days as I'm still "cooling off" and see if the system registers that the sim is in use.  I might ask them to send a new sim card out and do a sim swap, see if that kicks the system into life.

Message 7 of 20
1,285 Views

MI5
Level 94: Supreme
  • 120725 Posts
  • 605 Topics
  • 18184 Solutions
Registered:
Let us know how it goes mate
I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 8 of 20
1,275 Views

GMF
Level 2: Apprentice
  • 10 Posts
  • 1 Topics
  • 1 Solutions
Registered:

Sadly the SIM swap didn't work.

 

Do any of the O2 staff lurking here have any insight as to what's going wrong with 4G and Wifi calling at the moment?  Surely they don't want to drive another customer away? Looks like @joenitro has already cut and run 😞

 


@O2Adnan 
@O2Ben 
@O2Curtis 
@O2Dan 
@O2Danny 
@O2Elaine 
@O2Francesco 
@O2Faisal 
@O2Hannah 
@O2Heather 
@O2Jim 
@O2Jen 

@O2Jennifer 
@O2John 
@O2Jamie 
@O2James 
@O2Kat 
@O2Kurt 
@O2Lorna 
@O2Lauren 
@O2Michael 
@O2Sean 
@O2Sunil 
@O2Stephen 
@O2Stacey 

(sorry if i missed anyone)

Message 9 of 20
1,187 Views

O2John
  • 17 Posts
  • 0 Topics
  • 0 Solutions
Registered:

@GMF

 

There's a couple of things that spring to mind with this one. 

 

We did have issues lingering around numbers porting in last month, but I'm not aware of anything in particular. The other common issue is on handsets not supplied directly by O2, there's sometimes a firmware issue that prevents WiFi calling from working - although I've yet to encounter this on an iPhone, it's always been Android devices I've seen this on in the past.

 

None of us here will be able to resolve this, so I'll tag in @Marjo and @Martin to see if they can help you with escalating this to the right channels to find a resolution for you! 

signature
Message 10 of 20
1,174 Views