cancel
Showing results for 
Search instead for 
Did you mean: 

"Voice only"

Anonymous
Not applicable

I upgraded to the Blackberry Classic last week.  Everything has been working fine, but we went away at the weekend. Since then I've only been able to get "Voice only" on either 4G or 3G unless I connect to WiFi, which is a bit of a pain when out and about as I can now only get texts!

 

Any ideas?  

Message 1 of 12
5,737 Views
11 REPLIES 11

MI5
Level 94: Supreme
  • 121868 Posts
  • 607 Topics
  • 18766 Solutions
Registered:
Reset your service books and check that you have data enabled.
Also check your service status for any network issues.
I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 2 of 12
5,691 Views

MI5
Level 94: Supreme
  • 121868 Posts
  • 607 Topics
  • 18766 Solutions
Registered:
http://status.o2.co.uk/
I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 3 of 12
5,689 Views

Anonymous
Not applicable

Service status claims to be okay - and this has happened in 3 different towns - up to 120 miles apart!

 

Will give the service books a reset when I get home tonight, thank you 🙂

Message 4 of 12
5,683 Views

gmarkj
Level 55: Good Authority
  • 7981 Posts
  • 86 Topics
  • 510 Solutions
Registered:
check list of other things to go through:
-data settings (APN, etc) - recommend using geek squad website to get these
-data on tariff ok - could have standard data and not BB data (not sure if this is still valid...)
-your SIM in another phone (BB probably) and another SIM in your phone (again, would need to be as close a match as possible)
-if all else fails, try contacting o2 CS on 202 and get them to have a look at your account.


actually thought of something else - you have't used all of your allowance have you?

Please note, this is not customer services and we cannot access your account. Do not publish personal details (email, phone number, bank account).


Link to our guide on how to contact them can be found here

Message 5 of 12
5,678 Views

Anonymous
Not applicable
Thanks. Nope, second thing I checked after service was data, barely used 10% of it. Also looked at data settings via Geek Squad before coming here 🙂

Will try the reset then hassle o2 this evening!
Message 6 of 12
5,674 Views

gmarkj
Level 55: Good Authority
  • 7981 Posts
  • 86 Topics
  • 510 Solutions
Registered:
not a problem.
have had a similar issue after swapping phones only to discover some of the settings were a little off.
does the phone show 4G/3G/H or anything next to the signal bar? from your first post I would guess yes (otherwise you would not know if you were on it) but just wanted to cover it off.
good luck with the rest, and let us know how you get on.

Please note, this is not customer services and we cannot access your account. Do not publish personal details (email, phone number, bank account).


Link to our guide on how to contact them can be found here

Message 7 of 12
5,659 Views

Anonymous
Not applicable
Yeah, it worked a treat for 5 days then stopped! It was 4G now 4g. I'll get there 🙂
Message 8 of 12
5,655 Views

gmarkj
Level 55: Good Authority
  • 7981 Posts
  • 86 Topics
  • 510 Solutions
Registered:
definitely sounding more like an issue that CS needs to sort, possibly even a fault with the phone/SIM.
in order of "ease" to do - CS (phone, possibly live chat), SIM, then phone.

Please note, this is not customer services and we cannot access your account. Do not publish personal details (email, phone number, bank account).


Link to our guide on how to contact them can be found here

Message 9 of 12
5,651 Views

MI5
Level 94: Supreme
  • 121868 Posts
  • 607 Topics
  • 18766 Solutions
Registered:
Lower case 4g means not connected so resetting service books should fix it.
I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 10 of 12
5,649 Views