cancel
Showing results for 
Search instead for 
Did you mean: 

Cisco EHWIC-4G-LTE-G

jonnymk
Level 2: Apprentice
  • 39 Posts
  • 3 Topics
  • 0 Solutions
Registered:

Hi,

I was wondering if anyone has managed to sucessfully configure the EHWIC-4G-LTE-G network module for cisco routers like the 2911 to work with the o2 network?

 

I am succesfully registering to the o2 (network 10) in the uk (country 234) without roaming (home):

 

#sh cellular 0/0/0 network
Current Service Status = Normal
Current Service = Packet switched
Current Roaming Status = Home
Network Selection Mode = Automatic
Mobile Country Code (MCC) = 234
Mobile Network Code (MNC) = 10
Packet switch domain(PS) state = Attached
Registration(EMM) state = Registered

 

And I have a really good 3G (UMTS) signal (-31dBm is like 5 bars):

 

#sh cellular 0/0/0 radio
Radio power mode = ON
Current RSSI(RSCP) = -31 dBm
LTE Technology Preference = AUTO
LTE Technology Selected = UMTS

But the profile won't stay active.


If I ping an address on the internet like 8.8.8.8, the default route and chat-script bring the modem online and if I very quickly view the profile it does become active:

 

#sh cellular 0/0/0 profile
Profile 1 = ACTIVE*
--------
PDP Type = IPv4
PDP address = 10.122.1.178
Access Point Name (APN) = mobile.o2.co.uk
Authentication = Unknown
Username: bypass
Password:
        Primary DNS address = 82.132.254.2
        Secondary DNS address = 82.132.254.3

 

However, after a few seconds it always reverts back to the inactive state:

 

#sh cellular 0/0/0 profile
Profile 1 = INACTIVE*
--------
PDP Type = IPv4
Access Point Name (APN) = mobile.o2.co.uk
Authentication = Unknown
Username: bypass
Password:

 

This is repeatable and I have tried vertigo, bypass and o2web as different APNs. Here is the profile configuration I'm using:

 

#cellular 0/0/0 lte profile create 1 mobile.o2.co.uk pap bypass password ipv4

 

I have also tried a variety of chat-scripts like:

 

chat-script modem "" "AT!CALL1" TIMEOUT 30
chat-script modem "" "ATDT*99*1#" TIMEOUT 60 "OK"
chat-script modem "" "ATDT*99*1#" TIMEOUT 60 "CONNECT"
chat-script modem "" "ATDT*99***1#" TIMEOUT 60 "CONNECT"

 

To no avail. Here is the debug output that does not look good:

 

*Dec 23 16:10:56.907: CHAT0/0/0: Attempting async line dialer script
*Dec 23 16:10:56.907: CHAT0/0/0: process started
*Dec 23 16:10:56.907: CHAT0/0/0: Asserting DTR
*Dec 23 16:10:56.907: TTY0/0/0: no timer type 1 to destroy
*Dec 23 16:10:56.907: TTY0/0/0: no timer type 0 to destroy
*Dec 23 16:10:56.907: TTY0/0/0: no timer type 2 to destroy
*Dec 23 16:10:57.063: TTY0/0/0: DSR was dropped
*Dec 23 16:10:57.063: tty0/0/0: Modem: READY->(unknown).
*Dec 23 16:10:58.063: TTY0/0/0: dropping DTR, hanging up
*Dec 23 16:10:58.063: TTY0/0/0: Async Int reset: Dropping DTR

For reference, here is the rest of the configuration:

 

interface Cellular0/0/0
 ip address negotiated
 encapsulation slip
 dialer in-band
 dialer idle-timeout 0
 dialer string modem
 dialer-group 1
 async mode interactive
end
!
ip route 0.0.0.0 0.0.0.0 Cellular0/0/0
!
dialer-list 1 protocol ip permit
!
line 0/0/0
 exec-timeout 0 0
 script dialer modem
 modem InOut
 no exec
!

 

Any suggestions much appreciated.

Many thanks,
Jonny

Message 1 of 6
8,835 Views
5 REPLIES 5

Anonymous
Not applicable

Hi and Welcome to the forum,

 

 

 

I would suggest you finding a forum for cisci routers or use google.

 

Good luck.

Message 2 of 6
8,756 Views

jonnymk
Level 2: Apprentice
  • 39 Posts
  • 3 Topics
  • 0 Solutions
Registered:

Hi and thanks for the welcome. I did try searching the web and posting on the cisco forums and unfortuantely didn't find the complete answer on either. Problem is that if everyone "googles" everything but doens't post on forums like this, there isn't any decent information to "google" so in order to contribute below is my basic working solution (the trick was to encpasulate the packets with PPP inside SLIP):

 

!

ip dhcp pool LAN

network 192.168.1.0 255.255.255.0

default-router 192.168.1.1

dns-server 8.8.8.8 8.8.4.4

!

chat-script lte "" "AT!CALL1" TIMEOUT 30 "OK"

!

interface GigabitEthernet0/0

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly in

duplex auto

speed auto

!

interface Cellular0/0/0

ip address negotiated

ip nat outside

ip virtual-reassembly in

encapsulation slip

dialer in-band

dialer pool-member 1

dialer-group 1

async mode interactive

routing dynamic

!

interface Dialer1

ip address negotiated

ip nat outside

ip virtual-reassembly in

encapsulation ppp

dialer pool 1

dialer idle-timeout 0

dialer string lte

dialer persistent

dialer-group 1

ppp authentication pap callin

ppp pap sent-username o2web password 0 password

ppp ipcp dns request

!

ip forward-protocol nd

!

ip nat inside source list 1 interface Dialer1 overload

ip route 0.0.0.0 0.0.0.0 Dialer1

!

access-list 1 permit ip any

dialer-list 1 protocol ip permit

!

line 0/0/0

script dialer lte

modem InOut

no exec

transport input all

transport output all

rxspeed 100000000    <-- Populated automatically

txspeed 50000000     <-- Populated automatically

!

 

 

 

 

 

Message 3 of 6
8,716 Views

Anonymous
Not applicable

Thank you for sharing.

 

If someone has a similar issue then at least if they perform a search then a workaround is waiting for them.

 

Take care.

Message 4 of 6
8,713 Views

Anonymous
Not applicable

Hi @jonnymk,

The 4G only works with SLIP protocol and even if it shifts to 3G or 2G it still works with SLIP. I have the same problem as you mentioned above. In fact when i do debug chat, it gives me the following info. 

 

sending string OK

expecting string back OK

The connection timed out, the remote host not responding

 

Also i tried the working config but i get the same message. Please could someone confirm wether its an O2 or a config issue? Also i wasnt sure which username and password to use in the profile as O2 provided different ones which i tried all of them.

 

Thanks

 

 

 

 

Message 5 of 6
7,762 Views

Anonymous
Not applicable

Hi,

 

I have exactly the same issue as above - The connection timed out, the remote host not responding.

 

Can anyone help with this as it's driving me mad...?

 

Thanks...

 

Message 6 of 6
7,744 Views