cancel
Showing results for 
Search instead for 
Did you mean: 

Samsung watch 4 LTE sim not provisioned for voice

CP11
Level 1: Joiner
  • 3 Posts
  • 1 Topics
  • 0 Solutions
Registered:

Hi!

I am having no luck trying to get my watch connected for calls without my phone!

I went into the o2 store who set it all up and said its working I'm on a £5 a month plan for the watch. I get home take the dogs out and get sim not provisioned for voice on my watch!

 

Any suggestion on what to do next? Hoping this is a simple fix.

 

Thanks 😊 

Message 1 of 5
148 Views
4 REPLIES 4

MI5
Level 94: Supreme
  • 121953 Posts
  • 608 Topics
  • 18809 Solutions
Registered:

@CP11 

Go into the connection settings on your watch, turn on auto for data, turn on data roaming and then go to the network search setting on the watch and let it the watch search for the network, it should then register.
Next go to your mobile and in settings, advanced, turn on the switch to use your mobile data on other devices, make sure when you turn it on, it shows your Samsung watch at the bottom, tap and another screen comes up showing the watch is connected to your phone.
Reboot your watch and your mobile and you're done. Test it by leaving your phone in your home and take a walk, the watch should connect and show the 4g symbol and the mobile calling bars, if you try and make a call and it doesn't work or says connect to Bluetooth, go back and reboot the phone to make sure it's found the device, i.e. your watch. It will also say at the bottom of the watch, standalone, means your using the watch on it's own.

Remember to leave your phone on at all times, even if leaving it at home.

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 2 of 5
130 Views

CP11
Level 1: Joiner
  • 3 Posts
  • 1 Topics
  • 0 Solutions
Registered:

Thanks but still no luck

Message 3 of 5
124 Views

MI5
Level 94: Supreme
  • 121953 Posts
  • 608 Topics
  • 18809 Solutions
Registered:

@CP11 

If you've done all your setup correctly it must be that your account is not setup properly, so you need to go back to O2 to check all the account settings.

I suspect they haven't enabled the watch plan on your account.

I have no affiliation whatsoever with O2 or any subsidiary companies. Comments posted are entirely of my own opinion. This is not Customer Service so we are unable to help with account specific issues.

Currently using:
OnePlus 6 (O2 & Sfr), Z3 Tablet (Three UK), iPhone 8+ (EE)
Message 4 of 5
123 Views

CP11
Level 1: Joiner
  • 3 Posts
  • 1 Topics
  • 0 Solutions
Registered:

Thank you @MI5 I contacted them and apparently it is all active on their end. So still not sure why it's not working.

Message 5 of 5
111 Views