cancel
Showing results for 
Search instead for 
Did you mean: 

Suddenly no more texts from France

Amandine
Level 1: Joiner
  • 2 Posts
  • 1 Topics
  • 0 Solutions
Registered:
Hi all, I am on O2 business as my family is in France and I call/text them a lot. I’ve had the same number for 10 years and received texts fine but I noticed I suddenly can’t received texts from France (from different people and different networks) I’ve tried everything I saw in other messages but nothing has worked (weirdly when I try to check the message centre number I get an error message). I have an iPhone 8 Plus and I can text people but not receive. Thank you
Message 1 of 5
573 Views
4 REPLIES 4

Cleoriff
Level 94: Supreme
  • 106083 Posts
  • 790 Topics
  • 5416 Solutions
Registered:

@Amandine 

Have you tried rebooting the phone to see if you can restart the message centre?

For info the message centre numbers are

Pay Monthly +447802000332
Pay & Go +447802092035

and you can input them manually.

The other thing to check is Wifi calling. If you have it and it's turned on, then turn it off and see if that has any effect on your text messages. (It shouldn't affect it but it's worth a try)

Finally, you may need a new sim. You can pick one up instore or by calling O2 on any of the numbers in this guide Guide: Coronavirus Community Help and Support 

 

*The Game Is On*

Girl in a jacket
Message 2 of 5
568 Views

Amandine
Level 1: Joiner
  • 2 Posts
  • 1 Topics
  • 0 Solutions
Registered:
Hi Kleoriff, thanks for your response. The reboot and wifi calling tricks didn’t help but weirdly I can’t add the message centre number or even see it (I get an error message).. I will try and get a new SIM today and keep you posted!
Message 3 of 5
548 Views

Cleoriff
Level 94: Supreme
  • 106083 Posts
  • 790 Topics
  • 5416 Solutions
Registered:

@Amandine 

If you go instore for your new sim, mention there the problem with receiving texts messages. They may do a simple reset of your phone, to give it a kickstart.

Best of luck.

*The Game Is On*

Girl in a jacket
Message 4 of 5
544 Views

jonsie
Level 94: Supreme
  • 85688 Posts
  • 591 Topics
  • 4585 Solutions
Registered:

If you need to change the message centre number, follow this  guide:

Enter *#5005*7672#, then tap Call.

The current SMSC setting is shown on the screen. Tap Dismiss.

If the SMSC number needs changing, enter **5005*7672*SMSCNUMBER#, (where SMSCNUMBER is replaced with the correct SMSC number in full international format).

Message 5 of 5
525 Views